您的位置:首页 > 其它

POJ 1840 Eqs

2012-12-12 23:10 302 查看
 

 

Eqs

Time Limit: 5000MS

 

Memory Limit: 65536K

Total Submissions: 9567

 

Accepted: 4710

Description
Consider equations having the following form:

a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0

The coefficients are given integers from the interval [-50,50].

It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input
The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.
Output
The output will contain on the first line the number of the solutions for the given equation.
Sample Input
37 29 41 43 47

Sample Output
654

 

题解:简单哈希。数组定义成char型。

 

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;

const int MOD=19999999;
int ans[111];
char hashtb[MOD];

int main()
{
int n,cnt=0;
int a1,a2,a3,a4,a5;
for(int i=-50;i<=50;i++){
if(i==0)continue;
ans[cnt++]=i*i*i;
}
while(scanf("%d %d %d %d %d",&a1,&a2,&a3,&a4,&a5)!=EOF){
memset(hashtb,0,sizeof(hashtb));
for(int i=0;i<100;i++){
for(int j=0;j<100;j++)
for(int k=0;k<100;k++){
int temp=a1*ans[i]+a2*ans[j]+a3*ans[k];
if(temp<0) temp+=MOD;
temp=temp%MOD;
hashtb[temp]++;
}
}
cnt=0;
for(int i=0;i<100;i++){
for(int j=0;j<100;j++){
int temp=-(a4*ans[i]+a5*ans[j]);
if(temp<0) temp+=MOD;
temp=temp%MOD;
cnt+=hashtb[temp];
}
}
printf("%d\n",cnt);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: