您的位置:首页 > 其它

杭电OJ题 1040 As Easy As A+B 解题报告

2012-12-09 22:25 501 查看

As Easy As A+B

[align=center]Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 24750    Accepted Submission(s): 10426

[/align]

[align=left]Problem Description[/align]
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.

Give you some integers, your task is to sort these number ascending (升序).

You should know how easy the problem is now!

Good luck!

 

[align=left]Input[/align]
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and
then N integers follow in the same line.

It is guarantied that all integers are in the range of 32-int.

 

[align=left]Output[/align]
For each case, print the sorting result, and one line one case.

 

[align=left]Sample Input[/align]

2
3 2 1 3
9 1 4 7 2 5 8 3 6 9

 

[align=left]Sample Output[/align]

1 2 3
1 2 3 4 5 6 7 8 9

 
————————————————————————————————————————————————————————————————————

简单的排序问题

/***********************
* 程序名:As Easy As A+B.c
* 功能:ACM
************************/

#include <stdio.h>
int main()
{
int N, array[1000], i, j;
char num;
scanf("%d", &N);
getchar();
while(N--) {
i = 0;
while(scanf("%c", &num) && num != '\n') {
array[i++] = num - '0';
}
for(j = 0; j < i; j++) {
printf("%d ", array[j]);
}
}
return 0;
}

[align=left]Author[/align]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  ACM解题报告 SORT