您的位置:首页 > 其它

POJ 2485 Highways

2012-12-09 22:14 387 查看
Highways

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 16944Accepted: 7917
Description
The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways
so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.
Input
The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.
Output
For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.
Sample Input
1

3
0 990 692
990 0 179
692 179 0

Sample Output
692

Hint
Huge input,scanf is recommended.
Source
POJ Contest,Author:Mathematica@ZSU
解题思路:依然Prim,输出是所有最短路径中的最大值。
#include<iostream>
using namespace std;
#define INF 99999
long map[505][505];
long lowcost[505];
bool visit[505];
int N;
void Prim()
{
	int i,j,k,flag;
	long temp;
	for(i=2;i<=N;i++)
		lowcost[i]=map[1][i];
	for(i=1;i<N;i++)
	{
		temp=INF;
		for(j=2;j<=N;j++)
			if(temp>lowcost[j]&&!visit[j])
			{
				temp=lowcost[j];
				flag=j;
			}
			visit[flag]=true;
		for(k=1;k<=N;k++)
			if(lowcost[k]>map[flag][k]&&!visit[k])
				lowcost[k]=map[flag][k];
	}
}
int main()
{
	int i,j,test;
	long ans;
	cin>>test;
	while(test--)
	{
		ans=0;
		memset(visit,false,sizeof(visit));
		for(i=0;i<505;i++)
			for(j=0;j<=i;j++)
				if(i==j)
					map[i][j]=map[j][i]=0;
				else
					map[i][j]=map[j][i]=INF;
		cin>>N;
		for(i=1;i<=N;i++)
			for(j=1;j<=N;j++)
				cin>>map[i][j];
		Prim();
		for(i=2;i<=N;i++)
			if(ans<lowcost[i])
				ans=lowcost[i];
		cout<<ans<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: