您的位置:首页 > 其它

poj 2352 线段树

2012-12-08 02:11 363 查看
链接:http://poj.org/problem?id=2352

Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given
star. Astronomers want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a given map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at
one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5
1 1
5 1
7 1
3 3
5 5

Sample Output
1
2
1
1
0
题意:根据坐标的位置,求每个星星等级的个数,右边的星星及不高于它的满足条件.
花了一天时间终于弄出来了,哈哈~~
起初用线段树划分区间时,以纵坐标为基准的,弄半天没弄出来,后天发现以横坐标为基准,纵坐标本身是非递减的,才弄出来了.
以横坐标为基准,因为后来的坐标的纵坐标为非递减的,所以其等级是不会变的.
AC code:
#include<stdio.h>
#include<iostream>
#include<cstring>
using namespace std;
int sum(int a,int b) { return a+b; }
#define N 15001
#define M 32000
int ans
;
int s=0;
struct SegTree
{
int left,right,account;
}STree[M*4];
void build(int l,int r,int k)
{
STree[k].left=l;
STree[k].right=r;
STree[k].account=0;
if(l==r) return;
int mid=(l+r)/2;
build(l,mid,2*k);
build(mid+1,r,2*k+1);
}
void Insert(int x,int y,int k)
{
if(STree[k].left==x&&STree[k].right==x)
{
STree[k].account++;
return ;
}
int mid=(STree[k].left+STree[k].right)/2;
if(x<=mid)
Insert(x,y,2*k);
else if(x>mid)
Insert(x,y,2*k+1);
STree[k].account=sum(STree[2*k].account,STree[2*k+1].account);
}
void GetSum(int x,int k)
{
if(x==STree[k].right)
{
s+=STree[k].account;
return ;
}
int mid=(STree[k].left+STree[k].right)/2;
if(x<=mid)
GetSum(x,2*k);
else
{
GetSum(mid,2*k);
GetSum(x,2*k+1);
}
}
int main()
{
int i,num,x,y;
while(scanf("%d",&num)!=EOF)
{
memset(ans,0,sizeof(ans));
build(0,32000,1);
for(i=0;i<num;i++)
{
scanf("%d%d",&x,&y);
Insert(x,y,1);
s=0;
GetSum(x,1);
ans[s-1]++;
}
for(i=0;i<num;++i)
cout<<ans[i]<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: