您的位置:首页 > 其它

hdu 1405

2012-12-06 09:16 99 查看

The Last Practice

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5336 Accepted Submission(s): 1069



[align=left]Problem Description[/align]
Tomorrow is contest day, Are you all ready?

We have been training for 45 days, and all guys must be tired.But , you are so lucky comparing with many excellent boys who have no chance to attend the Province-Final.

Now, your task is relaxing yourself and making the last practice. I guess that at least there are 2 problems which are easier than this problem.

what does this problem describe?

Give you a positive integer, please split it to some prime numbers, and you can got it through sample input and sample output.

[align=left]Input[/align]
Input file contains multiple test case, each case consists of a positive integer n(1<n<65536), one per line. a negative terminates the input, and it should not to be processed.

[align=left]Output[/align]
For each test case you should output its factor as sample output (prime factor must come forth ascending ), there is a blank line between outputs.

[align=left]Sample Input[/align]

60
12
-1


[align=left]Sample Output[/align]

Case 1.
2 2 3 1 5 1

Case 2.
2 2 3 1
Hint
60=2^2*3^1*5^1


[align=left]Author[/align]
lcy

[align=left]Source[/align]
杭电ACM集训队训练赛(IV)

[align=left]Recommend[/align]
Ignatius.L

#include <stdio.h>
int main()
{
int n, c, count, i;
c = 1;
while(~scanf("%d", &n) && n > 0)
{
count = 0;
if(c != 1)//there is a blank line between outputs
printf("\n");
printf("Case %d.\n", c++);
if (n%2 == 0)
{
printf("2 ");
while(n%2 == 0)
{
count++;
n /= 2;
}
printf("%d ", count);
}
for (i = 3; i <= n; i += 2)
{
count = 0;
if(n%i == 0)
{
printf("%d ", i);
while(n%i == 0)
{
count++;
n /= i;
}
printf("%d ", count);//每个数字后都有一个空格,包括最后一个数字

}
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: