您的位置:首页 > 其它

POJ 2395 Out of Hay

2012-12-05 17:13 323 查看
Out of Hay

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 7469Accepted: 2788
Description
The cows have run out of hay, a horrible event
that must be remedied immediately. Bessie intends to visit the
other farms to survey their hay situation. There are N (2
<= N <= 2,000) farms (numbered 1..N);
Bessie starts at Farm 1. She'll traverse some or all of the M (1
<= M <= 10,000) two-way roads whose
length does not exceed 1,000,000,000 that connect the farms. Some
farms may be multiply connected with different length roads. All
farms are connected one way or another to Farm
1. 

Bessie is trying to decide how large a waterskin she will need. She
knows that she needs one ounce of water for each unit of length of
a road. Since she can get more water at each farm, she's only
concerned about the length of the longest road. Of course, she
plans her route between farms such that she minimizes the amount of
water she must carry. 

Help Bessie know the largest amount of water she will ever have to
carry: what is the length of longest road she'll have to travel
between any two farms, presuming she chooses routes that minimize
that number? This means, of course, that she might backtrack over a
road in order to minimize the length of the longest road she'll
have to traverse.

Input
* Line 1: Two space-separated integers, N and
M. 

* Lines 2..1+M: Line i+1 contains three space-separated integers,
A_i, B_i, and L_i, describing a road from A_i to B_i of length
L_i.

Output
* Line 1: A single integer that is the length of
the longest road required to be traversed.

Sample Input
3 3
1 2 23
2 3 1000
1 3 43


Sample Output
43


Hint
OUTPUT DETAILS: 

In order to reach farm 2, Bessie travels along a road of length 23.
To reach farm 3, Bessie travels along a road of length 43. With
capacity 43, she can travel along these roads provided that she
refills her tank to maximum capacity before she starts down a
road.

Source
USACO 2005
March Silver
最小生成树,求其中的最长的路径长度
代码:

C语言临时自用代码

#include<stdio.h>
#include<stdlib.h>
struct point{

    int x,y,lenth;
}map[10008];
int flag[2008];
int cmp(const void *a,const void *b)
{

    struct point *c,*d;

    c=(struct point *)a;

    d=(struct point *)b;

    return c->lenth-d->lenth;
}
int father(int x)
{

    if(x==flag[x])

        return x;

    flag[x]=father(flag[x]);

    return flag[x];
}
int main()
{

    int m,n,i,max,fa,fb;

    scanf("%d%d",&n,&m);

    for(i=0;i<m;i++)

        scanf("%d%d%d",&map[i].x,&map[i].y,&map[i].lenth);

    qsort(map,m,sizeof(map[0]),cmp);

    max=0;

    for(i=0;i<=n;i++)

        flag[i]=i;

    for(i=0;i<m;i++)

    {

        fa=father(map[i].x);

        fb=father(map[i].y);

        if(fa!=fb){

            if(fa>fb)

                flag[fa]=fb;

            else flag[fb]=fa;

            if(max<map[i].lenth)

                max=map[i].lenth;

        }

    }

    printf("%d\n",max);

    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: