您的位置:首页 > 其它

HDU  1025 Constructing Roads In …

2012-12-05 17:11 465 查看
Constructing Roads In JGShining's
Kingdom

Time Limit: 2000/1000 MS
(Java/Others)    Memory Limit:
65536/32768 K (Java/Others)
Total Submission(s): 5470
   Accepted Submission(s):
1596

Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000)
small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich
cities) while the others are short of resource (we call them poor
cities). Each poor city is short of exactly one kind of resource
and also each rich city is rich in exactly one kind of resource.
You may assume no two poor cities are short of one same kind of
resource and no two rich cities are rich in one same kind of
resource. 

With the development of industry, poor cities wanna import
resource from rich ones. The roads existed are so small that
they're unable to ensure the heavy trucks, so new roads should be
built. The poor cities strongly BS each other, so are the rich
ones. Poor cities don't wanna build a road with other poor ones,
and rich ones also can't abide sharing an end of road with other
rich ones. Because of economic benefit, any rich city will be
willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor
ones marked from 1 to n are located in Line
II. 

The location of Rich City 1 is on the left of all other
cities, Rich City 2 is on the left of all other cities excluding
Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich
City 2 but on the left of all other cities ... And so as the poor
ones. 

But as you know, two crossed roads may cause a lot of traffic
accident so JGShining has established a law to forbid constructing
crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and
handsome king of the kingdom - JGShining needs your help, please
help him. ^_^
 

Input
Each test case will begin with a line containing an integer
n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two
integers p and r which represents that Poor City p needs to import
resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of
sample. 
You should tell JGShining what's the maximal number of road(s)
can be built. 
 

Sample Input
2
1 2
2 1
3
1 2
2 3
3 1
 

Sample Output
Case 1:
My king, at most 1 road can be built.

Case 2:
My king, at most 2 roads can be built.

Hint

Huge input, scanf is recommended.
 
 

Author
最长上升子序列,不过数据比较大,明显用常规方法超时,方法见最长上升子序列(LIS)算法分析(做杭电
1025有感,特搜此文)这里还应用到了一点儿小技巧,就是存储数据用哈希存储,不用排序
代码:

#include<stdio.h>
int map[500008],flag[500008];
int main()
{
    int
n,i,top,hig,low,mid,t=0,a,b;
  
 while(scanf("%d",&n)!=EOF)
    {
    
   t++;
    
 
 for(i=1;i<=n;i++)
    
   {
    
     
 scanf("%d%d",&a,&b);
    
     
 map[a]=b;
    
   }
    
   flag[1]=map[1];top=1;
    
 
 for(i=2;i<=n;i++)
    
   {
    
     
   
 hig=top;low=1;
    
     
   
 while(low<=hig){
    
     
     
   mid=(low+hig)/2;
    
     
     
 
 if(flag[mid]<map[i])
    
     
     
     
 low=mid+1;
    
     
     
   else hig=mid-1;
    
     
     }
    
     
   
 flag[low]=map[i];
    
     
   
 if(low>top)top++;
    
   }
    
   printf("Case %d:\n",t);
    
   if(top==1)printf("My king, at
most %d road can be built.\n\n",top);
    
   else printf("My king, at most
%d roads can be built.\n\n",top);
    }
    return
0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐