您的位置:首页 > 其它

ZZULI_SummerPractice(3)   HDU  1…

2012-12-05 17:10 387 查看
E - Digital
Roots
p

Time Limit: 1000MSMemory Limit: 32768K64bit IO Format: %I64d & %I64u
[Submit]  
[Go Back]   [Status]

Description

The digital root of a positive integer is found by summing the
digits of the integer. If the resulting value is a single digit
then that digit is the digital root. If the resulting value
contains two or more digits, those digits are summed and the
process is repeated. This is continued as long as necessary to
obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the
4 yields a value of 6. Since 6 is a single digit, 6 is the digital
root of 24. Now consider the positive integer 39. Adding the 3 and
the 9 yields 12. Since 12 is not a single digit, the process must
be repeated. Adding the 1 and the 2 yeilds 3, a single digit and
also the digital root of 39.

 

Input

The input file will contain a list of positive integers, one
per line. The end of the input will be indicated by an integer
value of zero.

 

Output

For each integer in the input, output its digital root on a
separate line of the output.

 

Sample Input

24 39
0

 

Sample Output

6 3

这题我写都不想写啦,老掉牙的题,也不知道哪个学长出的题,

,但是还要记住,千万要用数组输入,不然你会死的很惨的,嘿嘿!

#include<stdio.h>

#include<string.h>

int main()

{

    char
str[1002];

    int
num,i,m;

   
while(gets(str),strcmp(str,"0")!=0)

    {

   
    num=0;

   
   
for(i=0;str[i];i++)

   
   
   
num+=str[i]-'0';

   
   
while(num>=10)

   
    {

   
   
    m=0;

   
   
   
while(num!=0)

   
   
    {

   
   
   
   
m+=num;

   
   
   
   
num=num/10;

   
   
    }

   
   
    num=m;

   
    }

   
   
printf("%d\n",num);

    }

    return
0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: