您的位置:首页 > 理论基础 > 计算机网络

天津网络赛 Examining the R…

2012-12-05 17:07 288 查看
原文地址:天津网络赛 Examining the Rooms作者:又岸

Examining the Rooms

Time
Limit: 2000/1000 MS
(Java/Others)    Memory
Limit: 32768/32768 K (Java/Others)

Total Submission(s):
260    Accepted
Submission(s): 137


[align=left]Problem Description[/align]
A murder happened in the hotel. As the best detective in the
town, you should examine all the N rooms of the hotel immediately.
However, all the doors of the rooms are locked, and the keys are
just locked in the rooms, what a trap! You know that there is
exactly one key in each room, and all the possible distributions
are of equal possibility. For example, if N = 3, there are 6
possible distributions, the possibility of each is 1/6. For
convenience, we number the rooms from 1 to N, and the key for Room
1 is numbered Key 1, the key for Room 2 is Key 2, etc.

To examine all the rooms, you have to destroy some doors by force.
But you don’t want to destroy too many, so you take the following
strategy: At first, you have no keys in hand, so you randomly
destroy a locked door, get into the room, examine it and fetch the
key in it. Then maybe you can open another room with the new key,
examine it and get the second key. Repeat this until you can’t open
any new rooms. If there are still rooms un-examined, you have to
randomly pick another unopened door to destroy by force, then
repeat the procedure above, until all the rooms are examined.

Now you are only allowed to destroy at most K doors by force.
What’s more, there lives a Very Important Person in Room 1. You are
not allowed to destroy the doors of Room 1, that is, the only way
to examine Room 1 is opening it with the corresponding key. You
want to know what is the possibility of that you can examine all
the rooms finally.
 

[align=left]Input[/align]
The first line of the input contains an integer T (T ≤ 200),
indicating the number of test cases. Then T cases follow. Each case
contains a line with two numbers N and K. (1 < N ≤
20, 1 ≤ K < N)
 

[align=left]Output[/align]
Output one line for each case, indicating the corresponding
possibility. Four digits after decimal point are preserved by
rounding.
 

[align=left]Sample Input[/align]

3
3 1
3 2
4 2

 

[align=left]Sample Output[/align]

0.3333

0.6667

0.6250

Hint
Sample Explanation When N = 3, there are 6 possible distributions
of keys: Room 1 Room 2 Room 3 Destroy Times #1 Key 1 Key 2 Key 3
Impossible #2 Key 1 Key 3 Key 2 Impossible #3 Key 2 Key 1 Key 3 Two
#4 Key 3 Key 2 Key 1 Two #5 Key 2 Key 3 Key 1 One #6 Key 3 Key 1
Key 2 One In the first two distributions, because Key 1 is locked
in Room 1 itself and you can’t destroy Room 1, it is impossible to
open Room 1. In the third and forth distributions, you have to
destroy Room 2 and 3 both. In the last two distributions, you only
need to destroy one of Room 2 or Room

 

[align=left]Source[/align]

The 35th ACM/ICPC Asia Regional Tianjin Site —— Online
Contest
 
 
 
这题要用到第一类 striling 数,属于数论上的东西。这是 一个解题报告

如果不考虑那个VIP,N个房间可以被最多K把钥匙打开的情况,实际上就是1..N的置换组成最多K个环的情况,这个就是第一类strling数之和S1
[1]
S1
[2] ...
S1
[k]。在这些情况里面,如果钥匙1恰好锁在房间1里也是不行的,所以还要减去N-1个房间被最多K-1把钥匙打开的情况数。
 

//第一类 斯特林数
#include<stdio.h>

#include<string.h>
long long fac[25]={1,1};

long long stri[25][25];
void str()

{

   
memset(stri,0,sizeof(stri));

   
stri[1][1]=1;

    for(int
i=2;i<=20;i )

    for(int
j=1;j<=i;j )

    {

       
stri[i][j]=stri[i-1][j-1] (i-1)*stri[i-1][j];

    }

}
int main()

{

    for(int
i=2;i<=20;i )

   
fac[i]=i*fac[i-1];

    int
test;

   
scanf("%d",&test);

   
str();//打表

   
while(test--)

    {

       
int n,k;

       
scanf("%d%d",&n,&k);

       
long long sum=0;

       
for(int i=1;i<=k;i )

       
{

           
sum =stri
[i]-stri[n-1][i-1];//这里要看清题

       
}

       
printf("%.4lfn",1.0*sum/fac
);
    }

    return
0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: