您的位置:首页 > 其它

POJ1645-Area(简单多边形面积计算)

2012-12-05 16:40 447 查看
[align=center]Area[/align]
Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 11130Accepted: 3173
Description
You are going to compute the area of a special kind of polygon. One vertex of the polygon is the origin of the orthogonal coordinate system. From this vertex, you may go step by step to the following vertexes of the polygon until back to the initial vertex. For each step you may go North, West, South or East with step length of 1 unit, or go Northwest, Northeast, Southwest or Southeast with step length of square root of 2.

For example, this is a legal polygon to be computed and its area is 2.5:


Input
The first line of input is an integer t (1 <= t <= 20), the number of the test polygons. Each of the following lines contains a string composed of digits 1-9 describing how the polygon is formed by walking from the origin. Here 8, 2, 6 and 4 represent North, South, East and West, while 9, 7, 3 and 1 denote Northeast, Northwest, Southeast and Southwest respectively. Number 5 only appears at the end of the sequence indicating the stop of walking. You may assume that the input polygon is valid which means that the endpoint is always the start point and the sides of the polygon are not cross to each other.Each line may contain up to 1000000 digits. Output
For each polygon, print its area on a single line. Sample Input
4  5  825  6725  6244865
Sample Output
0  0  0.5  2
题意:从原点出发,每次只能按照上下左右或者斜向行走一格,12346789分别代表不同的方向,输入行走轨迹,问走过的面积。
#include<stdio.h>
char cz[1000010];
int dir[10][2]={{0,0},{1,-1},{1,0},{1,1},{0,-1},{0,0},{0,1},{-1,-1},{-1,0},{-1,1}};
long long getarea(int x,int y,int x1,int y1)
{
return x*y1-y*x1;
}
int main()
{
int i,n,x,y,x1,y1;
long long s;
scanf("%d",&n);
while(n--)
{
scanf("%s",cz);
x=y=0;
for(i=0;cz[i]!=5;i++)
{
x1=x+dir[cz[i]-'0'][0];
y1=y+dir[cz[i]-'0'][1];
s+=getarea(x,y,x1,y1);
x=x1;
y=y1;
}
if(s<0) s=-s;
if(s%2==0) printf("%I64d\n",s/2);
else printf("%I64d.5\n",s/2);
}
return 0;
}
[code]
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: