您的位置:首页 > 其它

南阳理工:a letter and a number

2012-12-05 16:36 148 查看
a letter and a number
时间限制:3000 ms | 内存限制:65535 KB
难度:1
描述 we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;
Give you a letter x and a number y , you should output the result of y+f(x).
输入 On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000). 输出 for each case, you should the result of y+f(x) on a line 样例输入
6  R 1  P 2  G 3  r 1  p 2  g 3
样例输出
19  18  10  -17  -14  -4
#include<stdio.h>
int main()
{
int N,a;
char ch,c;
scanf("%d",&N);
while(N--)
{
c=getchar();
scanf("%c %d",&ch,&a);
if(ch>='A'&&ch<='Z')
printf("%d\n",ch-'A'+1+a);
else if(ch>='a'&&ch<='z')
printf("%d\n",'a'-ch-1+a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: