您的位置:首页 > 其它

hdu 1170

2012-12-04 08:59 127 查看

Balloon Comes!

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14959 Accepted Submission(s): 5382



[align=left]Problem Description[/align]
The contest starts now! How excited it is to see balloons floating around. You, one of the best programmers in HDU, can get a very beautiful balloon if only you have solved the very very very... easy problem.

Give you an operator (+,-,*, / --denoting addition, subtraction, multiplication, division respectively) and two positive integers, your task is to output the result.

Is it very easy?

Come on, guy! PLMM will send you a beautiful Balloon right now!

Good Luck!

[align=left]Input[/align]
Input contains multiple test cases. The first line of the input is a single integer T (0<T<1000) which is the number of test cases. T test cases follow. Each test case contains a char C (+,-,*, /) and two integers A and B(0<A,B<10000).Of
course, we all know that A and B are operands and C is an operator.

[align=left]Output[/align]
For each case, print the operation result. The result should be rounded to 2 decimal places If and only if it is not an integer.

[align=left]Sample Input[/align]

4
+ 1 2
- 1 2
* 1 2
/ 1 2


[align=left]Sample Output[/align]

3
-1
2
0.50


[align=left]Author[/align]
lcy

#include <iostream>
using namespace std;
int main()
{
int n, a, b;
char c;
cin>>n;
while (n--)
{
cin>>c>>a>>b;
if (c == '+')
{
cout<<a+b<<endl;
}
else if (c == '-')
{
cout<<a-b<<endl;
}
else if (c == '*')
{
cout<<a*b<<endl;
}
else if (c == '/')
{
if (a%b == 0)//attention: it is integer
cout<<a/b<<endl;
else
{
cout.setf(ios::fixed);
cout.precision(2);
cout<<1.0*a/b<<endl;
}
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: