您的位置:首页 > 其它

初级->基本算法->构造法 poj 3295 Tautology(永真式)

2012-12-03 23:49 543 查看
Tautology
Time Limit: 1000MS Memory Limit: 65536K

Total Submissions: 6734 Accepted: 2574

Description

WFF 'N PROOF is a logic game played with dice. Each die has six faces representing some subset of the possible symbols K, A, N, C, E, p, q, r, s, t. A Well-formed formula (WFF) is any string of these symbols obeying the following
rules:

p, q, r, s, and t are WFFs
if w is a WFF, Nw is a WFF
if w and x are WFFs, Kwx, Awx, Cwx, and Ewx are WFFs.
The meaning of a WFF is defined as follows:
p, q, r, s, and t are logical variables that may take on the value 0 (false) or 1 (true).
K, A, N, C, E mean and, or, not, implies, and equals as defined in the truth table below.

Definitions of K, A, N, C, and E
     w  x  Kwx  Awx   Nw  Cwx  Ewx
  1  1  1  1   0  1  1
  1  0  0  1   0  0  0
  0  1  0  1   1  1  0
  0  0  0  0   1  1  1
A tautology is a WFF that has value 1 (true) regardless of the values of its variables. For example, ApNp is a tautology because it is true regardless of the value of p. On the other hand, ApNq is
not, because it has the value 0 for p=0, q=1.

You must determine whether or not a WFF is a tautology.

Input

Input consists of several test cases. Each test case is a single line containing a WFF with no more than 100 symbols. A line containing 0 follows the last case.

Output

For each test case, output a line containing tautology or not as appropriate.

Sample Input
ApNp
ApNq
0


Sample Output
tautology
not


@優YoU

大致题意:

输入由p、q、r、s、t、K、A、N、C、E共10个字母组成的逻辑表达式,

其中p、q、r、s、t的值为1(true)或0(false),即逻辑变量;

K、A、N、C、E为逻辑运算符,

K --> and:  x && y

A --> or:  x || y

N --> not :  !x

C --> implies :  (!x)||y

E --> equals :  x==y

问这个逻辑表达式是否为永真式。

PS:输入格式保证是合法的

 

解题思路:

p, q, r, s, t不同的取值组合共32种情况,枚举不同取值组合代入逻辑表达式WFF进行计算。

如果对于所有的取值组合,WFF值都为 true, 则结果为 tautology,否则为 not。 

  

WFF的计算方法:

从字符串WFF的末尾开始依次向前读取字符。

构造一个栈stack,当遇到逻辑变量 p, q, r, s ,t 则将其当前的值压栈;

遇到 N 则取栈顶元素进行非运算,运算结果的值压栈;

遇到K, A, C, E则从栈顶中弹出两个元素进行相应的运算,将结果的值压栈。 

由于输入是合法的,当字符串WFF扫描结束时,栈stack中只剩一个值,该值就是逻辑表达式WFF的值。

#include<iostream>
#include<cstring>
#include<stack>
using namespace std;
int i,j,k,l,m;
stack<int>s;
int panduan(char var)
{
switch(var)
{
case 'p':s.push(i);return 1;
case 'q':s.push(j);return 1;
case 'r':s.push(k);return 1;
case 's':s.push(l);return 1;
case 't':s.push(m);return 1;
default :return 0;
}
return 0;
}
void ljys(char var)
{
int x,y;
switch(var)
{
case 'K':
{
x=s.top();
s.pop();
y=s.top();
s.pop();
s.push(x&&y);
break;
}
case 'A':
{
x=s.top();
s.pop();
y=s.top();
s.pop();
s.push(x||y);
break;
}
case 'C':
{
x=s.top();
s.pop();
y=s.top();
s.pop();
s.push((!x)||y);
break;
}
case 'N':
{
x=s.top();
s.pop();
s.push(!x);
break;
}
case 'E':
{
x=s.top();
s.pop();
y=s.top();
s.pop();
s.push(x==y);
break;
}
}
}
int main()
{
int len,n,flag,sum;
char wff[102];
while(cin>>wff&&wff[0]!='0')
{
len=strlen(wff);
flag=1;
for(i=0;i<=1;i++)
{
for(j=0;j<=1;j++)
{
for(k=0;k<=1;k++)
{
for(l=0;l<=1;l++)
{
for(m=0;m<=1;m++)
{
for(n=len-1;n>=0;n--)
{
if(!panduan(wff
))
ljys(wff
);
}
sum=s.top();
s.pop();
if(!sum)
{flag=0; break;}
}
if(!flag) break;
}
if(!flag) break;
}
if(!flag) break;
}
if(!flag) break;
}
if(flag) cout<<"tautology"<<endl;
else cout<<"not"<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: