您的位置:首页 > 其它

初级->基本算法->模拟 poj 1573 Robot Motion

2012-11-29 17:09 381 查看
Robot Motion

Time Limit: 1000MS Memory Limit: 10000K

Total Submissions: 8134 Accepted: 3933

Description

A robot has been programmed to follow the instructions in its path. Instructions for the next direction the robot is to move are laid down in a grid. The possible instructions are

N north (up the page)

S south (down the page)

E east (to the right on the page)

W west (to the left on the page)

For example, suppose the robot starts on the north (top) side of Grid 1 and starts south (down). The path the robot follows is shown. The robot goes through 10 instructions in the grid before leaving the grid.

Compare what happens in Grid 2: the robot goes through 3 instructions only once, and then starts a loop through 8 instructions, and never exits.

You are to write a program that determines how long it takes a robot to get out of the grid or how the robot loops around.

Input

There will be one or more grids for robots to navigate. The data for each is in the following form. On the first line are three integers separated by blanks: the number of rows in the grid, the number of columns in the grid, and the number of the column in
which the robot enters from the north. The possible entry columns are numbered starting with one at the left. Then come the rows of the direction instructions. Each grid will have at least one and at most 10 rows and columns of instructions. The lines of instructions
contain only the characters N, S, E, or W with no blanks. The end of input is indicated by a row containing 0 0 0.

Output

For each grid in the input there is one line of output. Either the robot follows a certain number of instructions and exits the grid on any one the four sides or else the robot follows the instructions on a certain number of locations once, and then the instructions
on some number of locations repeatedly. The sample input below corresponds to the two grids above and illustrates the two forms of output. The word "step" is always immediately followed by "(s)" whether or not the number before it is 1.

Sample Input

3 6 5

NEESWE

WWWESS

SNWWWW

4 5 1

SESWE

EESNW

NWEEN

EWSEN

0 0 0

Sample Output

10 step(s) to exit

3 step(s) before a loop of 8 step(s)

题目大意:模拟一个机器人在特定的棋盘中行走,每个棋盘的格子规定好了机器人移动的方向,每次移动只能走一个格子,问机器人退出棋盘时走的步数,如果不能退出棋盘,输出机器人进入循环前走的步数和每次循环中包含的步数。

思路:使用一个二维数组标记每个点的方向,经过的点标记为经过时的步数(为了防止与方向混淆,步数从4开始计)。

 

#include<stdio.h>
#include<string.h>
int map[11][11];
int dir[4][2]={{-1,0},{0,1},{1,0},{0,-1}};
int main()
{
int r,c,e,s,i,j,sum;
int s1,e1;
char ch;
while(scanf("%d%d%d",&r,&c,&e),r+c+e)
{
sum=4;
for(i=1;i<=r;i++)
{
getchar();
for(j=1;j<=c;j++)
{
scanf("%c",&ch);
switch(ch)
{
case 'N':map[i][j]=0;break;
case 'E':map[i][j]=1;break;
case 'S':map[i][j]=2;break;
case 'W':map[i][j]=3;break;
}
}
}
s=1;
while(s>=1&&s<=r&&e>=1&&e<=c&&map[s][e]<4)
{

s1=s+dir[map[s][e]][0];
e1=e+dir[map[s][e]][1];
map[s][e]=sum;
s=s1; e=e1;
sum++;
}
if(s>=1&&s<=r&&e>=1&&e<=c)
{
printf("%d step(s) before a",map[s][e]-4);
printf(" loop of %d step(s)\n",sum-map[s][e]);
}
else
printf("%d step(s) to exit\n",sum-4);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: