您的位置:首页 > 其它

hdu 1018 Big Number(纯数学公式)

2012-11-24 19:34 459 查看

Big Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17227 Accepted Submission(s): 7705



[align=left]Problem Description[/align]
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of
digits in the factorial of the number.

[align=left]Input[/align]
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each
line.

[align=left]Output[/align]
The output contains the number of digits in the factorial of the integers appearing in the input.

[align=left]Sample Input[/align]

2
10
20


[align=left]Sample Output[/align]

7
19


[align=left]Source[/align]
Asia 2002, Dhaka (Bengal)

[align=left]Recommend[/align]
JGShining

思路:///N!的位数=log(N!)/log(10);log(N!)=N*log(N)-N+0.5*log(2*m*pi);

失误点:注意函数重载,别CE了

///N!的位数=log(N!)/log(10);log(N!)=N*log(N)-N+0.5*log(2*m*pi);
#include<iostream>
#include<cmath>
using namespace std;
const double pi=3.1415926;
double sum;
int lowbit(int m)
{
double s=m*log((double)m)-m+0.5*log((double)2*m*pi);
s=s/log((float)10);
return (int)s+1;///如果是7.5位,则说明实际上是8位
}
int main()
{
int cas;
while(cin>>cas)
{
while(cas--)
{ int m;
cin>>m;
cout<<lowbit(m)<<"\n";
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: