您的位置:首页 > 其它

POJ 1338 Ugly Numbers

2012-11-23 23:45 316 查看
Ugly Numbers

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 16997Accepted: 7558
Description
Ugly numbers are numbers whose only prime factors are 2, 3 or 5. The sequence

1, 2, 3, 4, 5, 6, 8, 9, 10, 12, ...

shows the first 10 ugly numbers. By convention, 1 is included.

Given the integer n,write a program to find and print the n'th ugly number.

Input
Each line of the input contains a postisive integer n (n <= 1500).Input is terminated by a line with n=0.
Output
For each line, output the n’th ugly number .:Don’t deal with the line with n=0.
Sample Input
1
2
9
0

Sample Output
1
2
10

Source
New Zealand 1990 Division I,UVA 13
解题思路:从1开始向后乘,分别乘以2,3,5,记录下应加入数列的最小值,再改变乘数,用三个指针分别标示乘到哪个位置,最后完成一个完整数列,输出即可。
#include<iostream>
using namespace std;
long min(long a,long b,long c)
{
	if(a>b)
		a=b;
	if(a>c)
		a=c;
	return a;
}
int main()
{
	int i,n,p=1,q=1,r=1,t;
	long m1=2,m2=3,m3=5;
	long ans[1600];
	memset(ans,0,sizeof(ans));
	ans[1]=1;
	for(i=2;i<=1500;i++)
	{
		t=min(m1,m2,m3);
		ans[i]=t;
        if(t==m1)
			m1=ans[++p]*2;
		if(t==m2)
			m2=ans[++q]*3;
		if(t==m3)
			m3=ans[++r]*5;
	}
		while(cin>>n&&n)
			cout<<ans
<<endl;
	return 0;	
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: