您的位置:首页 > 其它

POJ 1256 Anagram

2012-11-22 23:00 309 查看
Anagram

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 15869Accepted: 6474
Description
You are to write a program that has to generate all possible words from a given set of letters.

Example: Given the word "abc", your program should - by exploring all different combination of the three letters - output the words "abc", "acb", "bac", "bca", "cab" and "cba".

In the word taken from the input file, some letters may appear more than once. For a given word, your program should not produce the same word more than once, and the words should be output in alphabetically ascending order.

Input
The input consists of several words. The first line contains a number giving the number of words to follow. Each following line contains one word. A word consists of uppercase or lowercase letters from A to Z. Uppercase and lowercase
letters are to be considered different. The length of each word is less than 13.
Output
For each word in the input, the output should contain all different words that can be generated with the letters of the given word. The words generated from the same input word should be output in alphabetically ascending order.
An upper case letter goes before the corresponding lower case letter.
Sample Input
3
aAb
abc
acba

Sample Output
Aab
Aba
aAb
abA
bAa
baA
abc
acb
bac
bca
cab
cba
aabc
aacb
abac
abca
acab
acba
baac
baca
bcaa
caab
caba
cbaa

Hint
An upper case letter goes before the corresponding lower case letter.

So the right order of letters is 'A'<'a'<'B'<'b'<...<'Z'<'z'.
Source
Southwestern European Regional Contest 1995
解题思路:水题一道,当然要感谢C++提供的强大的库函数(尤其是next_permutation()可以进行全排列,太帅了!)需要注意的是本题并不是要求按ASCII排列,而是按题目最后的要求进行排列。
#include<iostream>
#include<string>
#include<cstring>
#include<algorithm>
using namespace std;
bool cmp(char c1,char c2){
	if(tolower(c1) == tolower(c2)) //字母相同的话,大写在前,小写在后
		return c1 < c2;
	else                         //否则按字母表顺序从前到后排列
		return tolower(c1) < tolower(c2);
}
int main(){
	int n;
	cin >> n;
	int i;
        string str;
	for(i = 0; i < n; i++){
		cin >> str;
		sort(str.begin(),str.end(),cmp);//第一次排列
		do{
			cout << str << endl;
		}while(next_permutation(str.begin(),str.end(),cmp));//全排列直至最后一个
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: