您的位置:首页 > 其它

POJ1028 Web Navigation

2012-11-15 21:06 459 查看
Web Navigation

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 24561Accepted: 10944
Description

Standard web browsers contain features to move backward and forward among the pages recently visited. One way to implement these features is to use two stacks to keep track of the pages that can be reached by moving backward and forward. In this problem, you
are asked to implement this.

The following commands need to be supported:

BACK: Push the current page on the top of the forward stack. Pop the page from the top of the backward stack, making it the new current page. If the backward stack is empty, the command is ignored.

FORWARD: Push the current page on the top of the backward stack. Pop the page from the top of the forward stack, making it the new current page. If the forward stack is empty, the command is ignored.

VISIT : Push the current page on the top of the backward stack, and make the URL specified the new current page. The forward stack is emptied.

QUIT: Quit the browser.

Assume that the browser initially loads the web page at the URL http://www.acm.org/
Input

Input is a sequence of commands. The command keywords BACK, FORWARD, VISIT, and QUIT are all in uppercase. URLs have no whitespace and have at most 70 characters. You may assume that no problem instance requires more than 100 elements in each stack at any time.
The end of input is indicated by the QUIT command.

Output

For each command other than QUIT, print the URL of the current page after the command is executed if the command is not ignored. Otherwise, print "Ignored". The output for each command should be printed on its own line. No output is produced for the QUIT command.

Sample Input
VISIT http://acm.ashland.edu/ VISIT http://acm.baylor.edu/acmicpc/ BACK
BACK
BACK
FORWARD
VISIT http://www.ibm.com/ BACK
BACK
FORWARD
FORWARD
FORWARD
QUIT


Sample Output
http://acm.ashland.edu/ http://acm.baylor.edu/acmicpc/ http://acm.ashland.edu/ http://www.acm.org/ Ignored http://acm.ashland.edu/ http://www.ibm.com/ http://acm.ashland.edu/ http://www.acm.org/ http://acm.ashland.edu/ http://www.ibm.com/
Ignored


Source

East Central North America 2001

这是一道模拟网页浏览的题目,模拟访问网站,前进后退等。可以用类似链表的方法来储存网页间的前进后退关系。

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
struct node
{
    int back;//储存后退
    int forward;//储存前进
    char c[100];//网址
}p[150];
int main()
{
    for(int i=1;i<150;i++)
    {
        p[i].back=0;//默认0为没有
        p[i].forward=0;
    }
    int v=1;
    int index=1;
    strcpy(p[1].c,”http://www.acm.org/”);//首页
    string a;
    char b[100];
    while(cin>>a)
    {
        if(a==”QUIT”)return 0;
        if(a==”BACK”)
        {
            if(p[index].back==0)cout<<”Ignored”<<endl;//默认的0为没有后退项
            else
            {//此处更改链表
                cout<<p[p[index].back].c<<endl;
                p[p[index].back].forward=index;
                index=p[index].back;
            }
        }
        if(a==”FORWARD”)
        {
            if(p[index].forward==0)cout<<”Ignored”<<endl;//0为没有前进项
            else
            {//更改链表
                cout<<p[p[index].forward].c<<endl;
                p[p[index].forward].back=index;
                index=p[index].forward;
            }
        }
        if(a==”VISIT”)
        {
            scanf(“%s”,&p[++v].c);
            cout<<p[v].c<<endl;
            p[v].back=index;
            index=v;
        }
    }

     return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: