您的位置:首页 > 其它

zoj2100Seeding(水题)

2012-11-15 15:55 369 查看
Seeding
Time Limit: 2 Seconds      Memory Limit: 65536 KB
It is spring time and farmers have to plant seeds in the field. Tom has a nice field, which is a rectangle with n * m squares. There are big stones in some of the squares.
Tom has a seeding-machine. At the beginning, the machine lies in the top left corner of the field. After the machine finishes one square, Tom drives it into an adjacent square, and continues
seeding. In order to protect the machine, Tom will not drive it into a square that contains stones. It is not allowed to drive the machine into a square that been seeded before, either.
Tom wants to seed all the squares that do not contain stones. Is it possible?

Input
The first line of each test case contains two integers n and m that denote the size of the field. (1 < n, m < 7) The next n lines give the field, each of which contains m characters.
'S' is a square with stones, and '.' is a square without stones.
Input is terminated with two 0's. This case is not to be processed.

Output
For each test case, print "YES" if Tom can make it, or "NO" otherwise.

Sample Input
4 4

.S..

.S..

....

....

4 4

....

...S

....

...S

0 0


Sample Output

YES

NO

从左上角,一次性走完所有的点。

#include <iostream>
#include <cstring>
using namespace std;
const int MAXN = 10;
char maps[MAXN][MAXN];
bool visited[MAXN][MAXN];
const int moves[4][2] = {0,-1,1,0,-1,0,0,1};
int m,n,stone;
bool flag;

bool DFS(int x,int y,int level)
{
if(n * m - stone == level)
{
flag = true;
return true;
}
for(int i=0;i<4;i++)
{
int p = x + moves[i][0];
int q = y + moves[i][1];
if(p>=1&&p<=n&&q>=1&&q<=m&&maps[p][q]=='.'&&!visited[p][q])
{
visited[p][q] = true;
DFS(p,q,level+1);
if(flag) return true;
visited[p][q] = false;
}
}
return false;
}

int main()
{
freopen("in.txt","r",stdin);
int i,j;
while(cin>>n>>m&&n+m)
{
memset(maps,0,sizeof(maps));
memset(visited,false,sizeof(visited));
stone = 0;
for(i=1;i<=n;i++)
{
for(j=1;j<=m;j++)
{
cin>>maps[i][j];
if(maps[i][j]=='S')
stone++;
}
}
visited[1][1] = true;
flag = false;
bool ans = DFS(1,1,1);
if(ans) cout<<"YES"<<endl;
else cout<<"NO"<<endl;

}
}

当然可以不用visited数组

#include <iostream>
#include <cstring>
using namespace std;
#pragma warning(disable : 4996)
const int MAXN = 10;
char maps[MAXN][MAXN];
const int moves[4][2] = {{0, -1}, {0, 1}, {1, 0}, {-1, 0}};
int m, n, stone;
bool flag;

void DFS(int x, int y, int cnt)
{
if(stone + cnt == n * m)
{
flag = true;
return;
}
for(int i = 0; i < 4; i++)
{
int p = x + moves[i][0];
int q = y + moves[i][1];
if(p >= 1 && p <= n && q >= 1 && q <= m && maps[p][q] == '.')
{
maps[p][q] = 'S';
DFS(p, q, cnt + 1);
maps[p][q] = '.';
}
}
}

int main()
{
freopen("in.txt", "r", stdin);
int i, j;
while(cin >> n >> m)
{
if(n == 0 && m == 0)
{
break;
}
stone = 0;
for(i = 1; i <= n; i++)
{
for(j = 1; j <= m; j++)
{
cin >> maps[i][j];
if(maps[i][j] == 'S')
{
stone++;
}
}
}
flag = false;
maps[1][1] = 'S';
DFS(1, 1, 1);
if(flag)
{
cout << "YES" << endl;
}
else
{
cout << "NO" << endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: