您的位置:首页 > 产品设计 > UI/UE

Ahui Writes Word(01转化为多重背包)

2012-11-15 11:52 363 查看

Ahui Writes Word

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1235 Accepted Submission(s): 465

[/b]

[align=left]Problem Description[/align]
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters),
Ahui wrote the complexity of the total is less than or equal to C.

Question: the maximum value Ahui can get.

Note: input words will not be the same.

[align=left]Input[/align]
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)

Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)

[align=left]Output[/align]
Output the maximum value in a single line for each test case.

[align=left]Sample Input[/align]

5 20
go 5 8
think 3 7
big 7 4
read 2 6
write 3 5


[align=left]Sample Output[/align]

15
Hint
Input data is huge,please use “scanf(“%s”,s)”


[align=left]Author[/align]
Ahui

[align=left]Source[/align]
ACMDIY第二届群赛

[align=left]要点:由于N*V=10^9 数据量很大,用01背包解决肯定会超时。可是看看 w、c 的范围,0 ≤ Vi , Ci ≤ 10,重复的很多,可以转换为多重背包利用二进制优化。[/align]
#include <stdio.h>
#include <string.h>
#define maxn 10050
#define MAX 100050
int f[maxn];
int c[MAX],val[MAX],num[15][15];
int N,V;
int max(int x,int y)
{
return x>y?x:y;
}
void ZeroOnepace(int cost,int value)
{
int i;
for(i=V;i>=cost;i--)
f[i]=max(f[i],f[i-cost]+value);
}
void multipace(int cost,int value,int amount)
{
int i,k;
k=1;
while(k<amount)
{
ZeroOnepace(cost*k,value*k);
amount-=k;
k*=2;
}
ZeroOnepace(cost*amount,value*amount);
}
int main()
{
char name[100];
int i,j;
while(scanf("%d%d",&N,&V)==2)
{
memset(num,0,sizeof(num));
for(i=1;i<=N;i++)
{
scanf("%s",name);
scanf("%d%d",&val[i],&c[i]);
num[c[i]][val[i]]++;
}
memset(f,0,sizeof(f));
for(i=0;i<=10;i++)
for(j=0;j<=10;j++)
if(num[i][j]!=0)
multipace(i,j,num[i][j]);
printf("%d\n",f[V]);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: