您的位置:首页 > 其它

HDU 1071 The area

2012-11-13 23:00 621 查看

The area

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6335 Accepted Submission(s): 4433



[align=left]Problem Description[/align]
Ignatius bought a land last week, but he didn't know the area of the land because the land is enclosed by a parabola and a straight line. The picture below shows the area. Now given all the intersectant points shows in the picture,
can you tell Ignatius the area of the land?

Note: The point P1 in the picture is the vertex of the parabola.



[align=left]Input[/align]
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains three intersectant points which shows in the picture, they are given in the order of P1, P2, P3. Each point is described by two floating-point numbers X and Y(0.0<=X,Y<=1000.0).

[align=left]Output[/align]
For each test case, you should output the area of the land, the result should be rounded to 2 decimal places.

[align=left]Sample Input[/align]

2
5.000000 5.000000
0.000000 0.000000
10.000000 0.000000
10.000000 10.000000
1.000000 1.000000
14.000000 8.222222


[align=left]Sample Output[/align]

33.33
40.69

Hint
For float may be not accurate enough, please use double instead of float.


[align=left]Author[/align]
Ignatius.L
一道高数题 就是求出曲线和直线的方程在积分就好了!(曲线的方程可用顶点式 y = a(x-h)^2+l, (h,l) 为顶点坐标)

代码:

#include<stdio.h>

int main()

{ double x1,y1,x2,y2,x3,y3,k,h,a,b,c,area;int n;

while(scanf("%ld",&n)!=EOF)

{ while(n--)

{ area=0;

scanf("%lf%lf",&x1,&y1);

scanf("%lf%lf",&x2,&y2);

scanf("%lf%lf",&x3,&y3);

k=(y3-y2)/(x3-x2);

h=y2-k*x2;

a=(((y2-y1)/(x2-x1))-((y3-y2)/(x3-x2)))/(x1-x3);

b=((y2-y1)/(x2-x1))-(a *(x1+x2));

c=y3-(a*x3*x3+b*x3);

area=((a/3)*x3*x3*x3+((b-k)/2)*x3*x3+(c-h)*x3)-((a/3)*x2*x2*x2+((b-k)/2)*x2*x2+(c-h)*x2);

printf("%.2lf\n", area);

}

}

return 0;

内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: