您的位置:首页 > 其它

POJ 1017 Packets

2012-11-10 23:52 232 查看
Packets

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 37371Accepted: 12442
Description
A factory produces products packed in square packets of the same height h and of the sizes 1*1, 2*2, 3*3, 4*4, 5*5, 6*6. These products are always delivered to customers in the square parcels of the same height h as the products
have and of the size 6*6. Because of the expenses it is the interest of the factory as well as of the customer to minimize the number of parcels necessary to deliver the ordered products from the factory to the customer. A good program solving the problem
of finding the minimal number of parcels necessary to deliver the given products according to an order would save a lot of money. You are asked to make such a program.

Input
The input file consists of several lines specifying orders. Each line specifies one order. Orders are described by six integers separated by one space representing successively the number of packets of individual size from the
smallest size 1*1 to the biggest size 6*6. The end of the input file is indicated by the line containing six zeros.

Output
The output file contains one line for each line in the input file. This line contains the minimal number of parcels into which the order from the corresponding line of the input file can be packed. There is no line in the output
file corresponding to the last ``null'' line of the input file.
Sample Input
0 0 4 0 0 1 
7 5 1 0 0 0 
0 0 0 0 0 0

Sample Output
2 
1

Source
Central Europe 1996
解题思路:模拟题的水题,除6*6,5*5,4*4,三种必须单独占一个箱子,其余见缝插针,再把剩下拼不下的单独考虑即可。
#include<iostream>
using namespace std;
int Calculate(int a,int b,int c,int d,int e,int f)
{
	int u[4]={0,5,3,1};//打表
	int x,y,ans=0;
	ans=d+e+f+(c+3)/4;//6*6,5*5,4*4,三种必须各占一个箱子,3*3,每组少于等于四个占一个箱子,多的再加一个箱子
	y=5*d+u[c%4];//可供2*2箱子的位置
	if(b>y)//2*2箱子有的多的话,每少于等于9个编为一组,占一个箱子,多的再加一个箱子
		ans+=(b-y+8)/9;
	x=36*ans-36*f-25*e-16*d-9*c-4*b;//可供1*1箱子的位置
	if(a>x)//1*1箱子有的多的话,每少于等于36个编为一组,占一个箱子,多的再加一个箱子
		ans+=(a-x+35)/36;
    return ans;
}
int main()
{
	int A,B,C,D,E,F;
	while(cin>>A>>B>>C>>D>>E>>F)
	{
		if(A||B||C||D||E||F)
			cout<<Calculate(A,B,C,D,E,F)<<endl;
		else
			break;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: