您的位置:首页 > 其它

POJ 1562 Oil Deposits (DFS)

2012-11-04 23:12 459 查看
Oil Deposits

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 9776Accepted: 5356
Description

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil. A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.
Input

The input contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise 1 <= m <= 100 and 1 <= n <= 100. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either `*', representing the absence of oil, or `@', representing an oil pocket.

Output

are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.
Sample Input

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output

0
1
2
2

Source

Mid-Central USA 1997

//搜索练习题
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define N 102
char map

;
int m,n;
int dir[8][2]={-1,-1,-1,0,-1,1,0,-1,0,1,1,-1,1,0,1,1};
void dfs(int i,int j)
{
int x,y;
map[i][j]='*';
for(int k=0;k<8;k++)
{
x=i+dir[k][0];
y=j+dir[k][1];
if(x<0||x>=m||y<0||y>=n||map[x][y]=='*')
continue;
dfs(x,y);
}
}
int main()
{
int cnt;
while(scanf("%d %d",&m,&n),m||m)
{
int i,j;
cnt=0;
for(i=0;i<m;i++)
scanf("%s",map[i]);
for(i=0;i<m;i++)
for(j=0;j<n;j++)
{
if(map[i][j]=='@')
{
cnt++;
dfs(i,j);
}
}
printf("%d\n",cnt);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: