您的位置:首页 > 其它

poj 1753 Flip Game

2012-11-04 17:44 381 查看
Flip Game

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 21063Accepted: 9120
Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it's black or white side up. Each round you flip 3 to 5 pieces,
thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules:

Choose any one of the 16 pieces.

Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).


Consider the following position as an example:

bwbw

wwww

bbwb

bwwb

Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become:

bwbw

bwww

wwwb

wwwb

The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal.

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it's impossible to achieve the goal, then write the word "Impossible"
(without quotes).

Sample Input
bwwb
bbwb
bwwb
bwww


Sample Output
4


Source

Northeastern Europe 2000

分析:将图的一个状态哈希成一个唯一的值,比如:bwwbbbwbbwwbbwww

1*2^0+0*2^1+0*2^2+1*2^3+1*2^4+1*2^5+0*2^6+1*2^7+1*2^8+0*2^9+0*2^10+1*2^11+1*2^12+0*2^13+0*2^14+0*2^15=6585;
则全黑为65535,全白为0;这样做后,翻转一个位置得到新状态很容易求的state=state^(1<<x),x为翻转位置。
此方法虽巧妙,但局限在于N*N,N不能再大了!
#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<algorithm>
using namespace std;
void change(int& t,int k){t^=(1<<k);}
int flip(int sta,int n)
{
change(sta,n);
if(n>3)change(sta,n-4);
if(n<12)change(sta,n+4);
if(n%4!=0)change(sta,n-1);
if(n%4!=3)change(sta,n+1);
return sta;
}
int state;
void bfs()
{
int i,p,q;
queue<int> Q;
int v[65536];
memset(v,0,sizeof(v));
Q.push(state);
while(!Q.empty())
{
p=Q.front();Q.pop();
if(p==0||p==65535){printf("%d\n",v[p]);return;}
for(i=0;i<16;i++)
{
q=flip(p,i);
if(!v[q]){v[q]=v[p]+1;Q.push(q);}
}
}
puts("Impossible");
return;
}
int main()
{
int i;
char c;
state=0;
for(i=0;i<16;i++)
{
cin>>c;
state+=(c=='b'?1:0)<<i;
}
bfs();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: