您的位置:首页 > 其它

ZOJ_1240_IBM Minus One

2012-11-01 20:31 405 查看
IBM Minus One

Time Limit: 2 Seconds Memory Limit: 65536 KB

You may have heard of the book '2001 - A Space Odyssey' by Arthur C. Clarke, or the film of the same name by Stanley Kubrick. In it a spaceship is sent from Earth to Saturn. The crew
is put into stasis for the long flight, only two men are awake, and the ship is controlled by the intelligent computer HAL. But during the flight HAL is acting more and more strangely, and even starts to kill the crew on board. We don't tell you how the story
ends, in case you want to read the book for yourself :-)
After the movie was released and became very popular, there was some discussion as to what the name 'HAL' actually meant. Some thought that it might be an abbreviation for 'Heuristic
ALgorithm'. But the most popular explanation is the following: if you replace every letter in the word HAL by its successor in the alphabet, you get ... IBM.
Perhaps there are even more acronyms related in this strange way! You are to write a program that may help to find this out.

Input
The input starts with the integer n on a line by itself - this is the number of strings to follow. The following n lines each contain one string of at most 50 upper-case letters.

Output
For each string in the input, first output the number of the string, as shown in the sample output. The print the string start is derived from the input string by replacing every time
by the following letter in the alphabet, and replacing 'Z' by 'A'.
Print a blank line after each test case.

Sample Input
2

HAL

SWERC

Sample Output
String #1

IBM
String #2

TXFSD

题意和思路:什么叫做简单题???这个就是。。。难道一次就AC的题目.一个字符串每个字符都用后面的字符替代

Sample Program Here
/******************************************
**
**      Author: Wan KaiMing
**      Date:   2012-10-31-19.40
**
*******************************************/

#include<iostream>
#include<string>
#include<iomanip>
using namespace std;
int main(){
int n;//表示牌的数量
double s=0;//表示超出桌沿的距离
cout<<"# Cards  Overhang\n";
while(cin>>n){
s=0;
for(int i=1;i<=n;i++) s+=1.0/(2*i);
cout<<setw(5)<<n
<<setw(10)<<fixed<<setprecision(3)<<s<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: