您的位置:首页 > 其它

poj 3009 Curling 2.0

2012-10-30 19:46 363 查看
                                                                                                                                           Curling 2.0

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7356 Accepted: 3069
Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game
is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed
until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.



Fig. 1: Example of board (S: start, G: goal)
The movement of the stone obeys the following rules:

At the beginning, the stone stands still at the start square.
The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.

When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).

Once thrown, the stone keeps moving to the same direction until one of the following occurs:
The stone hits a block (Fig. 2(b), (c)).
The stone stops at the square next to the block it hit.
The block disappears.

The stone gets out of the board.
The game ends in failure.

The stone reaches the goal square.
The stone stops there and the game ends in success.

You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.



Fig. 2: Stone movements
Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).



Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board

First row of the board

...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <=
h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position
The dataset for Fig. D-1 is as follows:

6 6

1 0 0 2 1 0

1 1 0 0 0 0

0 0 0 0 0 3

0 0 0 0 0 0

1 0 0 0 0 1

0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input
2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output
1
4
-1
4
10
-1

题意: 一种类似于冰壶的游戏,2为开始点,3为终点,1为有石块儿的区域,0为没有石块的区域,方向只能是上下左右这样移动,且每次移动都是碰到石块后才停止,算为一步,碰到石块后,冰壶停在了石块的来的方向的上一个位置区域中,石块也随之破碎,求到达目的地的最短步数……

 

 

题解: 这道题开始的时候我用bfs做的 ,写了两天没有出来,后来再读题才发现石块破碎后就从棋盘上消失了,且回溯的时候应该恢复上一个情景,看了看网上的代码发现用bfs作的话碰到石块后仍然可以继续往下搜索,所以用dfs搜索有的路径进行比较…… 这道题的条件较多 ,第一次做,这个是仿照网上的代码写的……留着复习用了

代码:

#include<iostream>
#include<cstring>
using namespace std;
const int inf=11;
struct node
{
public:
int r,c;     //冰壶当前位置
bool status; //status冰壶当前状态:运动true ,静止false
}s,e;	//记录冰壶起止点
int w,h;  //场地size
int MinStep;  //最短路
int board[30][30];  //场地

void DFS(int i,int j,bool status,int direction,int step,bool flag)
{
//direction:冰壶当前运动方向  North:3  West:0  South:1  East:2
//flag:是否消除direction方向下一格位置的石头

if (step>10)  //剪枝,超过10步的走法就不再考虑了
return;

if (board[i][j]==3)  //终点
{
if (MinStep>step)
MinStep=step;
return;
}

if (flag) //消除石头
{
switch (direction)
{
case 0:
{
board[i-1][j]=0;
break;
}
case 1:
{
board[i][j-1]=0;
break;
}
case 2:
{
board[i+1][j]=0;
break;
}
case 3:
{
board[i][j+1]=0;
break;
}
}
}

if (!status)      //静止
{
if (i-1>=1 && (board[i-1][j]==0 || board[i-1][j]==3)) //West
DFS(i-1,j,true,0,step+1,false);

if (j-1>=1 && (board[i][j-1]==0 || board[i][j-1]==3)) //North
DFS(i,j-1,true,1,step+1,false);

if (i+1<=h && (board[i+1][j]==0 || board[i+1][j]==3)) //East
DFS(i+1,j,true,2,step+1,false);

if (j+1<=w && (board[i][j+1]==0 || board[i][j+1]==3)) //South
DFS(i,j-1,true,3,step+1,false);
}
else if (status) //运动
{
switch (direction)
{
case 0:
{
if (i-1<1) //预判下一步是否越界
return;
else
{
if (board[i-1][j]==0)         //下一位置为0且不越界,继续运动
DFS(i-1,j,true,0,step,false);
else if (board[i-1][j]==1)         //下一位置为1且不越界,停止运动,并消除下一位置的石头
DFS(i,j,false,0,step,true);
else if (board[i-1][j]==3)         //下一位置为3且不越界,运动到位置3后停止运动,游戏结束
DFS(i-1,j,false,0,step,false);
}

break;
}
case 1:
{
if (j-1<1) //预判下一步是否越界
return;
else
{
if (board[i][j-1]==0)         //下一位置为0且不越界,继续运动
DFS(i,j-1,true,1,step,false);
else if (board[i][j-1]==1)         //下一位置为1且不越界,停止运动,并消除下一位置的石头
DFS(i,j,false,1,step,true);
else if (board[i][j-1]==3)         //下一位置为3且不越界,运动到位置3后停止运动,游戏结束
DFS(i,j-1,false,1,step,false);
}

break;
}
case 2:
{
if (i+1>h) //预判下一步是否越界
return;
else
{
if (board[i+1][j]==0)         //下一位置为0且不越界,继续运动
DFS(i+1,j,true,2,step,false);
else if (board[i+1][j]==1)         //下一位置为1且不越界,停止运动,并消除下一位置的石头
DFS(i,j,false,2,step,true);
else if (board[i+1][j]==3)         //下一位置为3且不越界,运动到位置3后停止运动,游戏结束
DFS(i+1,j,false,2,step,false);
}

break;
}
case 3:
{
if (j+1>w) //预判下一步是否越界
return;
else
{
if (board[i][j+1]==0)         //下一位置为0且不越界,继续运动
DFS(i,j+1,true,3,step,false);
else if (board[i][j+1]==1)         //下一位置为1且不越界,停止运动,并消除下一位置的石头
DFS(i,j,false,3,step,true);
else if (board[i][j+1]==3)         //下一位置为3且不越界,运动到位置3后停止运动,游戏结束
DFS(i,j+1,false,3,step,false);
}

break;
}
}
}

if (flag) //回溯前还原石头,即还原上一步的棋盘状态
{
switch (direction)
{
case 0:
{
board[i-1][j]=1;
break;
}
case 1:
{
board[i][j-1]=1;
break;
}
case 2:
{
board[i+1][j]=1;
break;
}
case 3:
{
board[i][j+1]=1;
break;
}
}
}

return;
}

int main()
{
while (cin>>w>>h)
{
if (!w && !h)
break;

MinStep=inf;

for (int i=1;i<=h;i++)
for (int j=1;j<=w;j++)
{
cin>>board[i][j];

if (board[i][j]==2)
{
s.r=i;
s.c=j;
s.status=false;
board[i][j]=0;  //记录起点位置后,把它作为0处理
}
if (board[i][j]==3) //终点是特别位置,冰壶经过或到达该格都会停止
{
e.r=i;
e.c=j;
}
}

DFS(s.r , s.c , s.status , 0 , 0 , false);

if (MinStep<=10)
cout<<MinStep<<endl;   //DFS里面虽然剪枝了,但是可能把全部走法都剪了,因此还是要判断
else
cout<<-1<<endl;

}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: