您的位置:首页 > 其它

ZOJ_1151_Word Reversal

2012-10-29 15:50 423 查看
Word Reversal

Time Limit: 2 Seconds Memory Limit: 65536 KB

For each list of words, output a line with each word reversed without changing the order of the words.

This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank
line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.

Input
You will be given a number of test cases. The first line contains a positive integer indicating the number of cases to follow. Each case is given on a line containing a list of words
separated by one space, and each word contains only uppercase and lowercase letters.

Output
For each test case, print the output on one line.

Sample Input
1
3

I am happy today

To be or not to be

I want to win the practice contest

Sample Output
I ma yppah yadot

oT eb ro ton ot eb

I tnaw ot niw eht ecitcarp tsetnoc

题意和思路:这题折腾我了好久,其实不是道难题,可能太久没编程了 让我碰到很多细节问题,但是对自己的帮助还是很大,比如搞清了c和c++中string还有string.h还有gets和getline以及getchar和cin.ignore。现在说下题目意思,就是首先输入测试例数目,然后输入英文行数,然后让每个单词在原地翻转,一开始我是超时,用了STL的,后来全改用C来写并且没用任何STL,但是还是超时,后来才发现原来是题意理解不透彻,千万要注意比如测试cases为2
那么两组测试每次开始前都要输入n,可能没有人像我这么笨吧,就是cases和n要放在不同的循环中。

Sample Program Here
#include<stdio.h>
#include<string.h>
#define MAX 1000
int main(){
int cases,n;
scanf("%d",&cases);
char str[MAX];
char token[MAX];
int i,j,k;

while(cases--){
scanf("%d",&n);
getchar(); //不加参数则等价于cin.ignore(1,EOF);忽略结尾前的1个字符cin.ignore(1024,\n)也常用
while(n--){
gets(str);
int len=strlen(str);
k=0;
for(i=0;i<=len;i++){  //此处要去=len否则没有检查最后个单词后是否为空格就结束最后个单词没法输出

if(str[i]!=' '&&str[i]!=0){ //遇到空格说明一个单词结束进行反向输出,遇到回车表示一行结束
token[k++]=str[i];
}
else{
for(j=k-1;j>=0;j--)  printf("%c",token[j]);
if(str[i]!=0)  printf(" "); //若是结尾则不需要再输入空格了
k=0;
}
}

printf("\n"); //一行单词结束换行
}
if(cases!=0)
printf("\n");
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: