您的位置:首页 > 编程语言 > PHP开发

POJ 3981 字符串替换

2012-10-18 09:45 183 查看

一、题目信息

字符串替换

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7501 Accepted: 3560
Description

编写一个C程序实现将字符串中的所有"you"替换成"we"
Input

输入包含多行数据 

每行数据是一个字符串,长度不超过1000 

数据以EOF结束
Output

对于输入的每一行,输出替换后的字符串
Sample Input
you are what you do

Sample Output
we are what we do


二、参考代码

#include <string>
#include <iostream>
using namespace std;
int main()
{
string str;
while(getline(cin,str))
{
string::size_type pos = 0;
while ( (pos = str.find("you", pos)) != string::npos ) {
str.replace( pos++, 3, "we" );
}
cout << str << endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  string output c