您的位置:首页 > 其它

Is It A Tree?(并查集)

2012-10-14 10:31 260 查看

Is It A Tree?

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 13 Accepted Submission(s) : 7
[align=left]Problem Description[/align]
A tree is a well-known data structure that is either empty (null, void, nothing) or is a set of one or more nodes connected by directed edges between nodes satisfying the following
properties.

There is exactly one node, called the root, to which no directed edges point.

Every node except the root has exactly one edge pointing to it.

There is a unique sequence of directed edges from the root to each node.

For example, consider the illustrations below, in which nodes are represented by circles and edges are represented by lines with arrowheads. The first two of these are trees, but the last is not.







In this problem you will be given several descriptions of collections of nodes connected by directed edges. For each of these you are to determine if the collection satisfies the definition of a tree or not.

[align=left]Input[/align]
The input will consist of a sequence of descriptions (test cases) followed by a pair of negative integers. Each test case will consist of a sequence of edge descriptions followed
by a pair of zeroes Each edge description will consist of a pair of integers; the first integer identifies the node from which the edge begins, and the second integer identifies the node to which the edge is directed. Node numbers will always be greater than
zero.

[align=left]Output[/align]
For each test case display the line ``Case k is a tree." or the line ``Case k is not a tree.", where k corresponds to the test case number (they are sequentially numbered starting
with 1).

[align=left]Sample Input[/align]

6 8 5 3 5 2 6 4
5 6 0 0
8 1 7 3 6 2 8 9 7 5
7 4 7 8 7 6 0 0
3 8 6 8 6 4
5 3 5 6 5 2 0 0
-1 -1


[align=left]Sample Output[/align]

Case 1 is a tree.
Case 2 is a tree.
Case 3 is not a tree.


[align=left]Source[/align]
North Central North America 1997

题意:有多组数据,每组数据以“0 0”结束,当输入的两个数小于零时结束程序
每组数据判断是否成树,输入 a b 则b-->a
题解:并查集,此题要利用并查集将元素归并集合,因为输入 a b 则b-->a,即要判断b的父方,当f[a]==f[b]
即构成环或者b已有父方时则不成树,并且要判断是否为树而不是森林
#include<stdio.h>
#define MAXN 1010
int f[MAXN], r[MAXN],k[MAXN];
//f[]记录该节点的父节点,r[]记录该节点的子节点个数,k[]记录该节点是否出现过
int find(int x)
{
if(x!=f[x])
f[x]=find(f[x]);
return f[x];
}//查找父节点,路径压缩,其实,在这里已经把子节点都连接到根节点上了
int dec()
{
int i,t;
for(i=1;i<MAXN;i++)
if(k[i])
++r[find(i)];//累加对应根节点的子节点个数
t=0;
for(i=1;i<MAXN;i++)
if(r[i]>1)//判定根节点个数
t++;
if(t>1)//判定为树还是森林
return 0;
else return 1;
}
int main()
{
int i,c=0,x,y,a,b;
while(1)
{
int flag=0;
for(i=1;i<MAXN;i++)
{
f[i]=i;
r[i]=0;k[i]=0;
}
while(scanf("%d %d",&a,&b))
{
if((a==0&&b==0)||a<0)
break;
x=find(a);y=find(b);
k[a]=k[b]=1;
if(x==y||b!=y)//根节点相同则构成环,b!=y,则说明b已经有一个父节点了,即b的入度为2
flag=1;
else f[b]=a;
}
if(a<0)
break;
if(flag)
printf("Case %d is not a tree.\n",++c);
else {
if(dec())
printf("Case %d is a tree.\n",++c);
else printf("Case %d is not a tree.\n",++c);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: