您的位置:首页 > 理论基础 > 计算机网络

http://pat.zju.edu.cn/contests/pat-practise/1037

2012-10-13 09:55 447 查看
1037. Magic Coupon (25)

时间限制

100 ms

内存限制

32000 kB

代码长度限制

16000 B

判题程序

Standard

作者

CHEN, Yue

The magic shop in Mars is offering some magic coupons. Each coupon has an integer N printed on it, meaning that when you use this coupon with a product, you may get N times the value of that product back! What is more, the shop also offers some bonus product
for free. However, if you apply a coupon with a positive N to this bonus product, you will have to pay the shop N times the value of the bonus product... but hey, magically, they have some coupons with negative N's!

For example, given a set of coupons {1 2 4 -1}, and a set of product values {7 6 -2 -3} (in Mars dollars M$) where a negative value corresponds to a bonus product. You can apply coupon 3 (with N being 4) to product 1 (with value M$7) to get M$28 back; coupon
2 to product 2 to get M$12 back; and coupon 4 to product 4 to get M$3 back. On the other hand, if you apply coupon 3 to product 4, you will have to pay M$12 to the shop.

Each coupon and each product may be selected at most once. Your task is to get as much money back as possible.

Input Specification:

Each input file contains one test case. For each case, the first line contains the number of coupons NC, followed by a line with NC coupon integers. Then the next line contains the number of products NP, followed by a line with NP product values. Here 1<= NC,
NP <= 105, and it is guaranteed that all the numbers will not exceed 230.

Output Specification:

For each test case, simply print in a line the maximum amount of money you can get back.
Sample Input:
4
1 2 4 -1
4
7 6 -2 -3

Sample Output:
43


[cpp] view
plaincopy

#include<iostream>

#include<cstdio>

#include<memory.h>

#include<algorithm>

#include<cstring>

#include<queue>

#include<cmath>

#include<vector>

#include<cstdlib>

#include<cmath>

#include<iomanip>

#include<string>

using namespace std;

#define MAX 10000000000

int a1[100001],a2[100001];

int b1[100001],b2[100001];

long long c[100001];

void add(long long num){

c[0] += num;

for(int i=0;1;++i){

if(c[i]>=MAX){

c[i+1] += c[i]/MAX;

c[i] %= MAX;

}else if(c[i]==0){

break;

}

}

}

bool cmp(int a, int b){

return a>b;

}

int main(){

// freopen("in.txt", "r", stdin);

int t;

int n;

int n1,n2;

int m;

int m1, m2;

cin>>n;

n1=0,n2=0;

for(int i=0;i<n;++i){

scanf("%d", &t);

if(t>0)

a1[n1++] = t;

else if(t<0)

a2[n2++] = t;

}

cin>>m;

m1=0,m2=0;

for(int i=0;i<m;++i){

scanf("%d", &t);

if(t>0)

b1[m1++] = t;

else if(t<0)

b2[m2++] = t;

}

memset(c, 0, sizeof(c));

sort(a1, a1+n1, cmp);

sort(b1, b1+m1, cmp);

int len = n1>m1?m1:n1;

long long tmp;

for(int i=0;i<len;++i){

tmp = (long long)(a1[i]*b1[i]);

add(tmp);

}

sort(a2, a2+n2);

sort(b2, b2+m2);

len = n2>m2?m2:n2;

for(int i=0;i<len;++i){

tmp = (long long)(a2[i]*b2[i]);

add(tmp);

}

int k = 999;

bool first = true;

while(k>=0){

if(c[k]==0){

k--;

continue;

}

if(first){

printf("%lld", c[k]);

first = false;

}

else

printf("%10lld", c[k]);

k--;

}

if(first)

printf("0");

printf("\n");

//fclose(stdin);

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: