您的位置:首页 > 其它

HDU 1141 Factstone Benchmark

2012-10-12 15:47 323 查看


Factstone Benchmark

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 1057 Accepted Submission(s): 621



Problem Description

Amtel has announced that it will release a 128-bit computer chip by 2010, a 256-bit computer by 2020, and so on, continuing its strategy of doubling the word-size every ten years. (Amtel released a 64-bit computer in 2000, a 32-bit computer in 1990, a 16-bit
computer in 1980, an 8-bit computer in 1970, and a 4-bit computer, its first, in 1960.)

Amtel will use a new benchmark - the Factstone - to advertise the vastly improved capacity of its new chips. The Factstone rating is defined to be the largest integer n such that n! can be represented as an unsigned integer in a computer word.

Given a year 1960 ≤ y ≤ 2160, what will be the Factstone rating of Amtel's most recently released chip?

There are several test cases. For each test case, there is one line of input containing y. A line containing 0 follows the last test case. For each test case, output a line giving the Factstone rating.

Sample Input

1960
1981
0


Sample Output

3
8


Source

University of Waterloo Local Contest 2005.09.24

Recommend

Eddy

分析:题意就是找到最大的N使得N!<=芯片的位数,因为N!数字很大,所以考虑2边取对数来做log N+log N-1+.......+log 1=p*log 2

代码:

#include<stdio.h>
#include<math.h>

int main()
{
int n,i;
while(scanf("%d",&n))
{
if(n==0)
break;
int p=(n-1960)/10+2;
p=1<<p;
double sum=0;
i=0;
while(sum<p)
sum+=log((double)++i)/log((double)2);
printf("%d\n",i-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: