您的位置:首页 > 产品设计 > UI/UE

hdu 1394 Minimum Inversion Number

2012-10-09 22:27 302 查看

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5213    Accepted Submission(s): 3193


[align=left]Problem Description[/align]
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)

a2, a3, ..., an, a1 (where m = 1)

a3, a4, ..., an, a1, a2 (where m = 2)

...

an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

 

[align=left]Input[/align]
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

 

[align=left]Output[/align]
For each case, output the minimum inversion number on a single line.

 

[align=left]Sample Input[/align]

10
1 3 6 9 0 8 5 7 4 2

 

[align=left]Sample Output[/align]

16

 

[align=left]Author[/align]
CHEN, Gaoli
 

[align=left]Source[/align]
ZOJ Monthly, January 2003

 

[align=left]Recommend[/align]
Ignatius.L

线段树解法

#include<stdio.h>

#define MAXN 5001
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1

int sum[MAXN<<2];
int x[MAXN];

void PushUP(int rt)
{
sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void build(int l,int r,int rt)
{
sum[rt]=0;
if(l==r)
return ;
int m=(l+r)>>1;
build(lson);
build(rson);
}

void update(int tmp,int l,int r,int rt)
{
if(l==r)
{
sum[rt]++;
return ;
}
int m=(l+r)>>1;
if(m>=tmp)
update(tmp,lson);
else
update(tmp,rson);
PushUP(rt);
}

int query(int L,int R,int l,int r,int rt)
{
if(L<=l && r<=R)
return sum[rt];
int m=(l+r)>>1;
int res=0;
if(m>=L)
res+=query(L,R,lson);
if(m<R)
res+=query(L,R,rson);
return res;
}

int main(void)
{
int n;
while(~scanf("%d",&n))
{
build(0,n-1,1);
int i,sum=0;
for(i=1;i<=n;i++)
{
scanf("%d",&x[i]);
sum+=query(x[i],n-1,0,n-1,1);
update(x[i],0,n-1,1);
}
int min=sum;
for(i=1;i<n;i++)
{
sum+=n-x[i]-x[i]-1;
if(sum<min)
min=sum;
}
printf("%d\n",min);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息