您的位置:首页 > 其它

HDU 1076 An Easy Task

2012-10-09 16:07 309 查看


An Easy Task

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 9395 Accepted Submission(s): 5798



Problem Description

Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains two positive integers Y and N(1<=N<=10000).

Output

For each test case, you should output the Nth leap year from year Y.

Sample Input

3
2005 25
1855 12
2004 10000


Sample Output

2108
1904
43236

Hint
We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.


Author

Ignatius.L

分析:题意就是计算从Y年起第N个闰年是哪一年,因为数据量不大可以直接遍历

代码:

#include<stdio.h>

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int Y,N;
scanf("%d%d",&Y,&N);
int count=0;
while(1)
{
if((Y%4==0&&Y%100!=0)||Y%400==0)
{
count++;
Y++;
}
else
Y++;
if(count==N)
break;
}
printf("%d\n",Y-1);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: