您的位置:首页 > 其它

POJ 2104 K-th Number 划分树

2012-10-08 22:41 543 查看
Time Limit: 20000MSMemory Limit: 65536K
Total Submissions: 29149Accepted: 8799
Case Time Limit: 2000MS
Description

You are working for Macrohard company in data structures department. After failing your previous task about key insertion you were asked to write a new data structure that would be able to return quickly k-th order statistics in the array segment.
That is, given an array a[1...n] of different integer numbers, your
program must answer a series of questions Q(i, j, k) in the form: "What
would be the k-th number in a[i...j] segment, if this segment was
sorted?"

For example, consider the array a = (1, 5, 2, 6, 3, 7, 4). Let the
question be Q(2, 5, 3). The segment a[2...5] is (5, 2, 6, 3). If we sort
this segment, we get (2, 3, 5, 6), the third number is 5, and therefore
the answer to the question is 5.
Input

The
first line of the input file contains n --- the size of the array, and m
--- the number of questions to answer (1 <= n <= 100 000, 1 <=
m <= 5 000).

The second line contains n different integer numbers not exceeding 109 by their absolute values --- the array for which the answers should be given.

The following m lines contain question descriptions, each
description consists of three numbers: i, j, and k (1 <= i <= j
<= n, 1 <= k <= j - i + 1) and represents the question Q(i, j,
k).
Output

For each question output the answer to it --- the k-th number in sorted a[i...j] segment.
Sample Input

7 3
1 5 2 6 3 7 4
2 5 3
4 4 1
1 7 3

Sample Output

5
6
3

Hint

This problem has huge input,so please use c-style input(scanf,printf),or you may got time limit exceed.
Source

Northeastern Europe 2004, Northern Subregion

//第一道划分树题目
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <algorithm>
#define lson l,m,lv+1
#define rson m+1,r,lv+1
using namespace std;
#define N 100002
struct node
{
int num;
int v;
};
int rc
;
node st[20]
;
void build(int l,int r,int lv)
{
if(l==r) return ;
int m=(l+r)>>1;
int md=rc[m],ll=l,rr=m+1;
for(int i=l;i<=r;i++)
if(st[lv][i].v<=md)
{
i==l?st[lv][i].num=1:st[lv][i].num=st[lv][i-1].num+1;
st[lv+1][ll++].v=st[lv][i].v;
}
else
{
i==l?st[lv][i].num=0:st[lv][i].num=st[lv][i-1].num;
st[lv+1][rr++].v=st[lv][i].v;
}
build(lson);
build(rson);
}
void query(int ql,int qr,int qk,int l,int r,int lv)
{
if(l==r)
{
printf("%d\n",st[lv][l].v);
return ;
}
int m=(l+r)>>1;
int md=rc[m],lva=st[lv][l+ql-1].num,rva=st[lv][l+qr-1].num;
int num=rva-lva;
if(st[lv][l+ql-1].v<=md) num++;
if(num>=qk)
{
if(st[lv][l+ql-1].v<=md)
query(lva,rva,qk,lson);
else
query(lva+1,rva,qk,lson);
}
else
{
lva=ql-lva;
if(st[lv][l+ql-1].v<=md) lva++;
rva=qr-rva;
query(lva,rva,qk-num,rson);
}

}
int main()
{
int n,m;
int l,r,k;
while(scanf("%d %d",&n,&m)!=EOF)
{
for(int i=1;i<=n;i++) { scanf("%d",rc+i);st[0][i].v=rc[i];}
sort(rc+1,rc+n+1);
build(1,n,0);

while(m--)
{
scanf("%d %d %d",&l,&r,&k);
query(l,r,k,1,n,0);
}

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: