您的位置:首页 > 其它

HDU 1061 Rightmost Digit

2012-10-05 20:12 375 查看


Rightmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 19450 Accepted Submission(s): 7504



Problem Description

Given a positive integer N, you should output the most right digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the rightmost digit of N^N.

Sample Input

2
3
4


Sample Output

7
6

Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7.
In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.


Author

Ignatius.L

分析:找规律即可,像最后位是1的,不管多少个数相乘都是1,然后依次往下找,b[]代表每个数循环的个数

代码:

#include<stdio.h>

int a[10][5]={{0},{1},{2,4,8,6},{3,9,7,1},{4,6},{5},{6},{7,9,3,1},{8,4,2,6},{9,1}};
int b[10]={1,1,4,4,2,1,1,4,4,2};

int main()
{
int T;
scanf("%d",&T);
while(T--)
{
int n;
scanf("%d",&n);
int m;
m=n%10;
if(n%b[m]==0)
printf("%d\n",a[m][b[m]-1]);
else
printf("%d\n",a[m][n%b[m]-1]);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: