您的位置:首页 > 其它

HDU 1060 Leftmost Digit

2012-10-05 20:01 411 查看


Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8669 Accepted Submission(s): 3346



Problem Description

Given a positive integer N, you should output the leftmost digit of N^N.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single positive integer N(1<=N<=1,000,000,000).

Output

For each test case, you should output the leftmost digit of N^N.

Sample Input

2
3
4


Sample Output

2
2

Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.
In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.


Author

Ignatius.L

分析:设N^N=10^t Nlog10(N)=t,这样就把运行的阶数降下来了,然后floor(t)就是0的个数,所以我们只要取10^(t-floor(t))的个位数字就是我们要求的数字

代码:

#include<stdio.h>
#include<math.h>

int main()
{
int t;
scanf("%d",&t);
while(t--)
{
long n;
scanf("%ld",&n);
double temp=n*log10((double)n);
temp=temp-floor(temp);
printf("%d\n",(int)floor(pow(10,temp)));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: