您的位置:首页 > 其它

a letter and a number

2012-10-05 11:36 281 查看

a letter and a number

时间限制:3000 ms | 内存限制:65535 KB

难度:1
描述 we define f(A) = 1, f(a) = -1, f(B) = 2, f(b) = -2, ... f(Z) = 26, f(z) = -26;

Give you a letter x and a number y , you should output the result of y+f(x).
输入On the first line, contains a number T(0<T<=10000).then T lines follow, each line is a case.each case contains a letter x and a number y(0<=y<1000).输出for each case, you should the result of y+f(x) on a line样例输入
6
R 1
P 2
G 3
r 1
p 2
g 3

样例输出
19
18
10
-17
-14
-4


查看代码---运行号:252173----结果:Accepted

运行时间:2012-10-05 11:36:47 | 运行人:huangyibiao

view sourceprint?

01.
#include <iostream>

02.
using

namespace
std;

03.

04.
int

main()

05.
{

06.
int

testNum;

07.
cin >> testNum;

08.
char

letterX;

09.
int

numY;

10.
while

(testNum--)

11.
{

12.
cin >> letterX >> numY;

13.
if

(letterX -
'a'
>= 0)
//小写

14.
{

15.
cout << numY - (letterX -
'a'
) - 1 << endl;//别忘了-1

16.
}

17.
else

18.
cout << numY + (letterX -
'A'
) + 1 << endl;//别忘了加1

19.
}

20.
return

0;

21.
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: