您的位置:首页 > 其它

poj 1552 Doubles(简单的模拟一下)

2012-10-05 09:11 447 查看
Doubles

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 16425Accepted: 9404
Description

As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22


your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input

The
input will consist of one or more lists of numbers. There will be one
list of numbers per line. Each list will contain from 2 to 15 unique
positive integers. No integer will be larger than 99. Each line will be
terminated with the integer 0, which is not considered part of the list.
A line with the single number -1 will mark the end of the file. The
example input below shows 3 separate lists. Some lists may not contain
any doubles.
Output

The output will consist of one line per input list, containing a count of the items that are double some other item.
Sample Input

1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output

3
2
0

Source

分析:

(1)题意:求每行中有二倍关系的数字的组数。

(2)模拟,因为每行最多不超过14个数字,数字的范围是99以内所以开辟一个100大小的数组,使用标记位的方法标记这个数字是否存在,这样判断二倍关系是就方便了许多

Mid-Central USA 2003

#include <stdio.h>

int main()
{
int i,num[100],index,count;
while(1)
{
//将数组初始化-1
for(i=0;i<100;i++)num[i] = -1;
count = 0;
scanf("%d",&index);
if(index==-1)break;
while(1)
{
num[index]=1;
scanf("%d",&index);
if(index==0)break;
}
for(i=0;i<100;i++)
if(i*2<100&&num[i]==1&&num[i*2]==1)
count++;
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: