您的位置:首页 > 其它

POJ 3925 Minimal Ratio Tree 最小生成树

2012-10-04 14:15 357 查看
Description
For a tree, which nodes and edges are all weighted, the ratio of it is calculated according to the following equation.



Given a complete graph of n nodes with all nodes and edges weighted, your task is to find a tree, which is a sub-graph of the original graph, with m nodes and whose ratio is the smallest among all the trees of m nodes in the graph.
Input
Input contains multiple test cases. The first line of each test case contains two integers n (2<=n<=15) and m (2<=m<=n), which stands for the number of nodes in the graph and the number of nodes in the minimal ratio tree. Two zeros end the
input. The next line contains n numbers which stand for the weight of each node. The following n lines contain a diagonally symmetrical n×n connectivity matrix with each element shows the weight of the edge connecting one node with another. Of course, the
diagonal will be all 0, since there is no edge connecting a node with itself.

All the weights of both nodes and edges (except for the ones on the diagonal of the matrix) are integers and in the range of [1, 100].

The figure below illustrates the first test case in sample input. Node 1 and Node 3 form the minimal ratio tree.



Output
For each test case output one line contains a sequence of the m nodes which constructs the minimal ratio tree. Nodes should be arranged in ascending order. If there are several such sequences, pick the one which has the smallest node number;
if there's a tie, look at the second smallest node number, etc. Please note that the nodes are numbered from 1.
Sample Input
3 2 30 20 10 0 6 2 6 0 3 2 3 0 2 2 1 1 0 2 2 0 0 0
Sample Output
1 3 1 2

#include<cstdio>

#include<cmath>

using namespace std;

#define M 30

#define MAX 900000000

int w[M],g[M][M];

int n,m;

int ans[M];

int node[M];

double minans;

void prim()

{

bool used[M];

int dis[M];

int i,j,nd=1;

double totale,totaln;

totale=totaln=0;

for(i=0;i<m;i++)

{

used[i]=false;

dis[i]=MAX;

}

used[0]=true;

for(i=0;i<m;i++)

{

dis[i]=g[ node[0] ][ node[i] ];

}

while(nd<m)

{

int min=MAX;

int mini=0;

for(i=0;i<m;i++)

{

if(!used[i]&&dis[i]<min)

{

min=dis[i];

mini=i;

}

}

used[mini]=true;

totale+=min;

nd++;

for(i=0;i<m;i++)

{

if(!used[i]&&g[ node[mini] ][ node[i] ] < dis[i])

{

dis[i] = g[ node[mini] ][ node[i] ];

}

}

}

for(i=0;i<m;i++)

{

totaln+=w[ node[i] ];

}

double now=totale/totaln;

if(abs(now-minans)>0&&now<minans)

{

minans=now;

for(i=0;i<m;i++)

{

ans[i]=node[i];

}

}

}

void fun(int ns,int num)

{

if(ns==m)

{

prim();

return ;

}

for(int i=num;i<n;i++)

{

node[ns]=i;

fun(ns+1,i+1);

}

}

int main()

{

int i,j;

while(~scanf("%d%d",&n,&m))

{

if(n==0&&m==0)

{

break;

}

for(i=0;i<n;i++)

{

scanf("%d",w+i);

}

for(i=0;i<n;i++)

{

for(j=0;j<n;j++)

{

scanf("%d",&g[i][j]);

}

}

minans=MAX;

fun(0,0);

printf("%d",ans[0]+1);

for(i=1;i<m;i++)

{

printf(" %d",ans[i]+1);

}

putchar(10);

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: