您的位置:首页 > 其它

POJ 2352 线段树

2012-10-04 14:12 183 查看
Description
Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers
want to know the distribution of the levels of the stars.



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level
0, two stars of the level 1, one star of the level 2, and one star of the level 3.

You are to write a program that will count the amounts of the stars of each level on a g.iven map.
Input
The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of
the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

Output
The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
Sample Input
5

1 1

5 1

7 1

3 3

5 5
Sample Output
1

2

1

1

0

Source::

#include<cstdio>

using namespace std;

#define M 70005

struct Node

{

int l,r;

int n;

}a[M];

int ans[M];

void build(int l,int r,int num)

{

a[num].l=l;

a[num].r=r;

a[num].n=0;

if(l<r)

{

build(l,(l+r)/2,num*2);

build((l+r)/2+1,r,num*2+1);

}

}

void insert(int l,int num)

{

if(a[num].l==l&&a[num].r==l)

{

a[num].n++;

return ;

}

int mid=(a[num].l+a[num].r)/2;

if(l<=mid)

{

insert(l,num*2);

}

else

{

insert(l,num*2+1);

}

a[num].n++;

}

int find(int l,int r,int num)

{

if(a[num].l==l&&a[num].r==r)

{

return a[num].n;

}

int mid=(a[num].l+a[num].r)/2;

if(l>mid)

{

return find(l,r,num*2+1);

}

else if(r<=mid)

{

return find(l,r,num*2);

}

else

{

return find(l,mid,num*2)+find(mid+1,r,num*2+1);

}

}

int main()

{

int x,y,n;

int max=32001;

while(~scanf("%d",&n))

{

build(0,max,1);

for(int i=0;i<n;i++)

{

scanf("%d%d",&x,&y);

ans[find(0,x,1)]++;

insert(x,1);

}

for(int i=0;i<n;i++)

{

printf("%d\n",ans[i]);

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: