您的位置:首页 > 其它

HDU 1020 Encoding

2012-10-04 09:07 281 查看


Encoding

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 17115 Accepted Submission(s): 7316



Problem Description

Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC


Sample Output

ABC
A2B3C


Author

ZHANG Zheng

Recommend

JGShining

分析:题意很清楚,但是注意ABBACCC应该是A2BA3C而不是2A2B3C

代码:

#include<stdio.h>
#include<string.h>
char s[10001];

int main()
{
int T;
scanf("%d",&T);
getchar();
while(T--)
{
int len,i,j;
int count=1;
gets(s);
len=strlen(s);
for(i=0;i<len;)
{
for(j=i+1;j<len;j++)
{
if(s[i]==s[j])
count++;
else
break;
}
if(count!=1)
printf("%d",count);
printf("%c",s[i]);
i+=count;
count=1;
}
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: