您的位置:首页 > 其它

poj 1401 Factorial(数学水题)

2012-10-03 20:21 411 查看
Factorial

Time Limit: 1500MSMemory Limit: 65536K
Total Submissions: 12345Accepted: 7693
Description

The most important part of a GSM network is so called Base Transceiver Station (BTS). These transceivers form the areas called cells (this term gave the name to the cellular phone) and every phone connects to the BTS with the strongest signal (in a little simplified view). Of course, BTSes need some attention and technicians need to check their function periodically.

ACM technicians faced a very interesting problem recently. Given a
set of BTSes to visit, they needed to find the shortest path to visit
all of the given points and return back to the central company building.
Programmers have spent several months studying this problem but with no
results. They were unable to find the solution fast enough. After a
long time, one of the programmers found this problem in a conference
article. Unfortunately, he found that the problem is so called
"Travelling Salesman Problem" and it is very hard to solve. If we have N
BTSes to be visited, we can visit them in any order, giving us N!
possibilities to examine. The function expressing that number is called
factorial and can be computed as a product 1.2.3.4....N. The number is
very high even for a relatively small N.

The programmers understood they had no chance to solve the problem.
But because they have already received the research grant from the
government, they needed to continue with their studies and produce at
least some results. So they started to study behaviour of the factorial
function.

For example, they defined the function Z. For any positive integer
N, Z(N) is the number of zeros at the end of the decimal form of number
N!. They noticed that this function never decreases. If we have two
numbers N1 < N2, then Z(N1) <= Z(N2). It is because we can never
"lose" any trailing zero by multiplying by any positive number. We can
only get new and new zeros. The function Z is very interesting, so we
need a computer program that can determine its value efficiently.

Input

There is
a single positive integer T on the first line of input. It stands for
the number of numbers to follow. Then there is T lines, each containing
exactly one positive integer number N, 1 <= N <= 1000000000.
Output

For every number N, output a single line containing the single non-negative integer Z(N).
Sample Input

6
3
60
100
1024
23456
8735373

Sample Output

0
14
24
253
5861
2183837
注意:
(1)这是一道数学问题,主要题意是,计算N!的尾部有多少个0.
(2)数学问题,就不能是愚蠢的计算,而是分析数学方法公式等计算。
(3)每次只计算最多含有5,5^2,5^3……的数字个数 每次含有5的[n/5] ........25.[n/25]
注意,当统计最多含有5^2的因子的时候,5的个数应该为[n/25]而不是[n/25]*2因为,在含有[n/5]的时候已经统计过一次了 所以,只需要把[n/5],[n/25]...加起来就可以


#include <stdio.h>

int main()
{
int t,n,i,count;
scanf("%d",&t);
while(t--)
{
count = 0;
scanf("%d",&n);
for(i=5;i<=n;i*=5)
count += n/i;
printf("%d\n",count);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: