您的位置:首页 > 编程语言 > PHP开发

zoj 3203 Light Bulb(三分)

2012-10-02 09:35 459 查看
Light Bulb
Time Limit: 1 Second
Memory Limit: 32768 KB
Compared to wildleopard's wealthiness, his brother mildleopard is rather poor. His house is narrow and he has only one light bulb in his house. Every night, he is wandering in his incommodious house, thinking of how to earn more money. One day, he found
that the length of his shadow was changing from time to time while walking between the light bulb and the wall of his house. A sudden thought ran through his mind and he wanted to know the maximum length of his shadow.



Input

The first line of the input contains an integer T (T <= 100), indicating the number of cases.

Each test case contains three real numbers H, h and D in one line.H is the height of the light bulb while
h is the height of mildleopard.D is distance between the light bulb and the wall. All numbers are in range from 10-2 to 103, both inclusive, andH -
h >= 10-2.

Output

For each test case, output the maximum length of mildleopard's shadow in one line, accurate up to three decimal places..

Sample Input

3
2 1 0.5
2 0.5 3
4 3 4


Sample Output

1.000
0.750
4.000

如图,人左右走动,求影子L的最长长度。
根据图,很容易发现当灯,人的头部和墙角成一条直线时(假设此时人站在A点),此时的长度是影子全在地上的最长长度。当人再向右走时,影子开始投影到墙上,当人贴着墙,影子长度即为人的高度。所以当人从A点走到墙,函数是先递增再递减,为凸性函数,所以我们可以用三分法来求解。

根据三角形相似列出方程:设在地上的那段影子的长度为l1,  l1/D=(h-L)/(H-L),得到l1=(h-L)*D/(H-L),所以影子的总长度为l1+L=(h-L)*D/(H-L)+L,只有一个未知数L,把L进行三分,在(0,h)这个范围内。

#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
#include<math.h>
#define eps 1e-15
using namespace std;
double D,h,H;
int sgn(double a)
{
return (a>eps)-(a<-eps);
}
double dist(double x)
{
return x+(h-x)*D/(H-x);
}
double work()
{
double mid,midmid;
double l,r;l=0;r=h;
while(sgn(r-l)>0)
{
mid=(l+r)*0.5;
midmid=(mid+r)*0.5;
if(dist(mid)>=dist(midmid))
r=midmid;
else
l=mid;
}
return dist(r);
}
int main()
{
int t;
double ff;
scanf("%d",&t);
while(t--)
{
scanf("%lf%lf%lf",&H,&h,&D);
printf("%.3lf\n",work());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息