您的位置:首页 > 其它

poj2689 Prime Distance 素数筛选应用 复习

2012-10-01 13:05 232 查看
Prime Distance

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 8409Accepted: 2273
Description
The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number
that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers
that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.

Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair.
You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).
Input
Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output
For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input
2 17
14 17

Sample Output
2,3 are closest, 7,11 are most distant.
There are no adjacent primes.

Source
Waterloo local 1998.10.17
//这题的l,u比较大,无法用数组将素数存起来,所以必须灵活运用素数筛选的原理。
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
using namespace std;
const int N=50000;
long prime
={0},num_prime=0;
int isNotPrime
={1,1};
int dis[1000010];
void sushu()
{
    for(long i=2;i<N;i++)
    {
        if(!isNotPrime[i])
        prime[num_prime++]=i;
        for(long j=0;j<num_prime&&i*prime[j]<N;j++)
        {
            isNotPrime[i*prime[j]]=1;
            if(!(i%prime[j]))
            break;
        }
    }
}
int main()
{
    long long  l,u;
    sushu();
    while(scanf("%lld%lld",&l,&u)!=EOF)
    {
       for(long long  i=l;i<=u;i++)
       dis[i-l]=0;//假设一开始[l,u]全是素数
       for(int i=0;i<num_prime;i++)//利用素数筛选的原理,用已知的素数把[l,u]之间一些数筛掉
       {
           long long  j=l/prime[i];
           if(j*prime[i]>u) break;
           if(l%prime[i]) j++;
           if(j==1) j++;
           for(;j*prime[i]<=u;j++)//素数的倍数落在[l,u]这个区间的要筛掉
           {
               dis[j*prime[i]-l]=1;
              //cout<<(j*prime[i]-l)<<"&"<<endl;
           }
       }
       long long  pi;
       for(long long  i=l;i<=u;i++)
       {
           if(!dis[i-l])
           {
               pi=i;
               break;
           }
       }
       if(pi==1)
       pi++;
       //cout<<pi<<endl;
       long long  m1,m2,n1,n2;
       int minn=1000001;
       int maxn=-1;
       for(long long  i=pi+1;i<=u;i++)
       {
           if(!dis[i-l])
           {
               int f=i-pi;
               if(f<minn)
               {
                  minn=f;
                  m1=pi;
                  m2=i;
               }
               if(f>maxn)
               {
                   maxn=f;
                   n1=pi;
                   n2=i;
               }
               pi=i;
           }
       }
       if(minn!=1000001&&maxn!=-1)
       {
           printf("%lld,%lld are closest, %lld,%lld are most distant.\n",m1,m2,n1,n2);
       }
       else
       printf("There are no adjacent primes.\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: