您的位置:首页 > 大数据 > 人工智能

poj 3714 Raid(最小点对变形)

2012-09-26 18:27 375 查看
Raid

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 5479Accepted: 1661
Description

After successive failures in the battles against the Union, the Empire retreated to its last stronghold. Depending on its powerful defense system, the Empire repelled the six waves of Union's attack. After several sleepless nights of thinking, Arthur, General
of the Union, noticed that the only weakness of the defense system was its energy supply. The system was charged by N nuclear power stations and breaking down any of them would disable the system.

The general soon started a raid to the stations by N special agents who were paradroped into the stronghold. Unfortunately they failed to land at the expected positions due to the attack by the Empire Air Force. As an experienced general, Arthur
soon realized that he needed to rearrange the plan. The first thing he wants to know now is that which agent is the nearest to any power station. Could you, the chief officer, help the general to calculate the minimum distance between an agent and a station?

Input

The first line is a integer T representing the number of test cases.

Each test case begins with an integer N (1 ≤ N ≤ 100000).

The next N lines describe the positions of the stations. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the station.

The next following N lines describe the positions of the agents. Each line consists of two integers X (0 ≤ X ≤ 1000000000) and Y (0 ≤ Y ≤ 1000000000) indicating the positions of the agent.  

Output

For each test case output the minimum distance with precision of three decimal placed in a separate line.

Sample Input
2
4
0 0
0 1
1 0
1 1
2 2
2 3
3 2
3 3
4
0 0
0 0
0 0
0 0
0 0
0 0
0 0
0 0

Sample Output
1.414
0.000

Source

POJ Founder Monthly Contest – 2008.12.28, Dagger
题目:http://poj.org/problem?id=3714
题意:给你两类点,都是n个,求这两类点间的最小距离

分析:我们可以把两类点合并,然后求最近点对,每次求距离都在两类点之间求即可。。。

代码:

#include<cmath>
#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
const int mm=222222;
typedef double diy;
struct point
{
    diy x,y;
    bool flag;
}g[mm];
int q[mm];
int n,t;
bool cmp(point P,point Q)
{
    return P.x<Q.x;
}
bool cmpy(int a,int b)
{
    return g[a].y<g[b].y||(g[a].y==g[b].y&&g[a].flag<g[b].flag);
}
diy Dis(point P,point Q)
{
    return sqrt((P.x-Q.x)*(P.x-Q.x)+(P.y-Q.y)*(P.y-Q.y));
}
diy NearPoint(int l,int r)
{
    if(l>=r)return 1e30;
    int i,j,n=0,m=(l+r)>>1;
    diy a=min(NearPoint(l,m),NearPoint(m+1,r));
    for(i=m;i>=l;--i)
        if(g[m].x-g[i].x<a)q[n++]=i;
        else break;
    for(i=m+1;i<=r;++i)
        if(g[i].x-g[m].x<a)q[n++]=i;
        else break;
    sort(q,q+n,cmpy);
    for(i=0;i<n;++i)
        if(!g[q[i]].flag)
            for(j=i+1;j<n;++j)
                if(g[q[j]].y-g[q[i]].y<a)
                {
                    if(g[q[j]].flag)a=min(a,Dis(g[q[i]],g[q[j]]));
                }
                else break;
    return a;
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        for(int i=0;i<n;++i)
            scanf("%lf%lf",&g[i].x,&g[i].y),g[i].flag=0;
        for(int i=n ;i<n+n;++i)
            scanf("%lf%lf",&g[i].x,&g[i].y),g[i].flag=1;
        n=n+n;
        sort(g,g+n,cmp);
        printf("%.3lf\n",NearPoint(0,n-1));
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: