您的位置:首页 > 其它

杭电OJ--1013 Digital Roots

2012-09-23 17:53 561 查看


Digital Roots

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Problem Description

The digital root of a positive integer is found by summing the digits of the integer. If the resulting value is a single digit then that digit is the digital root. If the resulting value contains two or more digits, those digits are summed and the process is
repeated. This is continued as long as necessary to obtain a single digit.

For example, consider the positive integer 24. Adding the 2 and the 4 yields a value of 6. Since 6 is a single digit, 6 is the digital root of 24. Now consider the positive integer 39. Adding the 3 and the 9 yields 12. Since 12 is not a single digit, the process
must be repeated. Adding the 1 and the 2 yeilds 3, a single digit and also the digital root of 39.



Input

The input file will contain a list of positive integers, one per line. The end of the input will be indicated by an integer value of zero.



Output

For each integer in the input, output its digital root on a separate line of the output.



Sample Input

24
39
0




Sample Output

6
3



虽然是一道水题,但是不知道规律之前还是很悲催的,所以在这里记录一下代码和方法!已备不时之需!

/**********
结果:超时!
***********
#include<stdio.h>
#include<stdlib.h>
int main()
{
    char buff[100];
    int num,i=1;
    while(scanf("%d",&num)!=EOF)
    {
        if(num==0) return 0;
        while(1)
        {
            itoa(num,buff,10);
            for(i=0,num=0;buff[i]!='\0';i++)//i是buff的长度
             num=num+buff[i]-'1'+1;    
            if(i==1) 
            {
                printf("%d\n",num);
                break;
            }

        }
    }
    return 0;
}
/**************************

/**************************
问题:wa!原因:测试数据太大!
**************************************/
/*************************************
#include<stdio.h>

int main()
{
    int num;
    while(scanf("%d",&num)!=EOF)
    {
        if(num==0) return 0;
        printf("%d\n",num%9?9:num%9);
        
    }
    return 0;
}
***************************************/
//合九法:一个数的数字根等于这个数模9,也等于各个位所有数之和模9。
#include<stdio.h>
#include<string.h>
int main()
{
    char  num[1000];
    int len,sum,i;
    while(scanf("%s",&num)!=EOF)
    {
        len=strlen(num);
        if(len==1 && num[0]=='0') return 0;
        for(sum=0,i=0;i<len;i++)
        {
            sum=sum+num[i]-'0';
        }
        printf("%d\n",sum%9?sum%9:9);//合九法;一个数的数字根等于这个数模9,也等于各个位所有数之和模9
        
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: