您的位置:首页 > 其它

poj2262

2012-09-23 07:45 183 查看
Goldbach's Conjecture

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 30655Accepted: 11849
Description

In 1742, Christian Goldbach, a German amateur mathematician, sent a letter to Leonhard Euler in which he made the following conjecture:

Every even number greater than 4 can be

written as the sum of two odd prime numbers.

For example:

8 = 3 + 5. Both 3 and 5 are odd prime numbers.

20 = 3 + 17 = 7 + 13.

42 = 5 + 37 = 11 + 31 = 13 + 29 = 19 + 23.

Today it is still unproven whether the conjecture is right. (Oh wait, I have the proof of course, but it is too long to write it on the margin of this page.)

Anyway, your task is now to verify Goldbach's conjecture for all even numbers less than a million.

Input

The input will contain one or more test cases.

Each test case consists of one even integer n with 6 <= n < 1000000.

Input will be terminated by a value of 0 for n.

Output

For each test case, print one line of the form n = a + b, where a and b are odd primes. Numbers and operators should be separated by exactly one blank like in the sample output below. If there is more than one pair of odd primes adding up to n, choose the pair
where the difference b - a is maximized. If there is no such pair, print a line saying "Goldbach's conjecture is wrong."

Sample Input
8
20
42
0


Sample Output
8 = 3 + 5
20 = 3 + 17
42 = 5 + 37


这个题目只要用筛选法求出素数就可以了。。。。。

#include <iostream>
#include<stdio.h>
#include<string.h>
#include<math.h>

#define NUMBER 1000000
using namespace std;

bool primer1[NUMBER+1];
int primer[NUMBER/3];

int getprimer()
{
for(int i=1;i<=NUMBER;i++)
{
primer1[i]=1;
}
primer1[1]=0;
for(int i=2;i<=sqrtf(NUMBER);i++)
{
if(primer1[i])
{
for(int j=i;j*i<=NUMBER;j++)
{
primer1[j*i]=0;
}
}
}
int count=0;
for(int i=2;i<=NUMBER;i++)
{
if(primer1[i])
{
primer[++count]=i;
}
}
return count;
}

void deal(int a,int count)
{
bool temp=false;
int b;

for(int i=2;i<=count;i++)
{
if(primer[i]>a)break;
if(primer1[a-primer[i]])
{
temp=true;
b=primer[i];
break;
}
}
cout<<a<<" = "<<b<<" + "<<a-b<<endl;
}

int main()
{
//freopen("in.txt","r",stdin);
int n;
int count=getprimer();
while(cin>>n,n)
{
deal(n,count);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: