您的位置:首页 > 编程语言 > PHP开发

hdu 2602 Bone Collector 简单dp题 0-1背包

2012-09-19 00:48 411 查看


Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 14600    Accepted Submission(s): 5817


Problem Description

Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …

The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the
maximum of the total value the bone collector can get ?

 

Input

The first line contain a integer T , the number of cases.

Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third
line contain N integers representing the volume of each bone.

 

Output

One integer per line representing the maximum of the total value (this number will be less than 231).

 

Sample Input

1
5 10
1 2 3 4 5
5 4 3 2 1

 

Sample Output

14

 

Author

Teddy

虽然说是简单 但是也是做了好久才做出来 中间wa了好几次  1是标准的模版中没有考虑到vol==0的情况 就有好多物品有价值但是木有体积

2 数组清零少清了几个 悲剧了

#include<stdio.h>
#include<stdio.h>
struct node{
int weight,value;
}a[1100];
int ans[1100];

int main()
{
int x,n,vol,i,j;
scanf("%d",&x);
while(x--)
{
scanf("%d %d",&n,&vol);
for( i=1; i<=n; i++)
scanf("%d",&a[i].value);
for( i=1; i<=n; i++)
scanf("%d",&a[i].weight);
if(vol==0){ //考虑体积为0 的特殊情况 注意有物品价值有但是体积为0
int sum=0;
for(i=1;i<=n;i++)
{
if(a[i].weight==0)sum+=a[i].value;
}
printf("%d\n",sum);
continue;
}
for( i=1; i<=vol; i++)
ans[i]=-1;
ans[0]=0;

for( j=1; j<=n; j++) //0-1背包的模版 进行动归
{
for( i=vol; i>=0 ;i--)
{
if(ans[i]!=-1){
if( i+a[j].weight<=vol && (ans[i]+a[j].value > ans[ i+ a[j].weight ] ) )
ans[i+a[j].weight]= (ans[i]+a[j].value);
}
}
}
int max=0;
for(i=1;i<=vol;i++)
if(ans[i]>max)max=ans[i];
printf("%d\n",max);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  integer each output less input