您的位置:首页 > 其它

POJ 3264 Balanced Lineup RMQ问题的ST解法

2012-09-15 22:28 337 查看
Balanced Lineup

Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 24349Accepted: 11348
Case Time Limit: 2000MS
Description

For the daily milking, Farmer John's N cows (1 ≤ N ≤ 50,000) always line up in the same order. One day Farmer John decides to organize a game of Ultimate Frisbee with some of the cows. To keep things simple, he will take a contiguous range of cows from the milking lineup to play the game. However, for all the cows to have fun they should not differ too much in height.

Farmer John has made a list of Q (1 ≤ Q ≤ 200,000) potential groups of cows and their heights (1 ≤ height ≤ 1,000,000). For each group, he wants your help to determine the difference in height between the shortest and the tallest cow in the group.

Input

Line 1: Two space-separated integers, N and Q.
Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i

Lines N+2..N+Q+1: Two integers A and B (1 ≤ A ≤ B ≤ N), representing the range of cows from A to B inclusive.
Output

Lines 1..Q:
Each line contains a single integer that is a response to a reply and
indicates the difference in height between the tallest and shortest cow
in the range.
Sample Input

6 3
1
7
3
4
2
5
1 5
4 6
2 2

Sample Output

6
3
0

Source

USACO 2007 January Silver
RMQ问题的ST解法、第一次用,1Y,呵呵
开学后课好多,课程任务好重、都没什么时间做题目、学算法、烦呀
#include <iostream>
#include <stdio.h>
#define N 50010
#include <cmath>
using namespace std;
int f_min
[18];
int f_max
[18];

int main()
{
// cout<<(1<<16);
int n,q;
int i,j,k,t;
int h,l;
// printf("%d ",k);
while(scanf("%d %d",&n,&q)!=EOF)
{
for(i=1;i<=n;i++)
{
scanf("%d",&f_min[i][0]);
f_max[i][0]=f_min[i][0];
}
k=(int)(log(n*1.0)/log(2*1.0));
for(i=1;i<=k;i++)
{
t=(1<<i);
for(j=1;j<=n-t+1;j++)
{
f_max[j][i]=max(f_max[j][i-1],f_max[j+t/2][i-1]);
f_min[j][i]=min(f_min[j][i-1],f_min[j+t/2][i-1]);

}
}
while(q--)
{
scanf("%d %d",&i,&j);
k=(int)(log((j-i+1)*1.0)/log(2*1.0));
t=(1<<k);
h=max(f_max[i][k],f_max[j-t+1][k]);
l=min(f_min[i][k],f_min[j-t+1][k]);
printf("%d\n",h-l);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: