您的位置:首页 > 其它

hdu 1175 连连看(DFS)

2012-09-15 01:38 375 查看

连连看

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10237    Accepted Submission(s): 2695

[align=left]Problem Description[/align]
“连 连看”相信很多人都玩过。没玩过也没关系,下面我给大家介绍一下游戏规则:在一个棋盘中,放了很多的棋子。如果某两个相同的棋子,可以通过一条线连起来 (这条线不能经过其它棋子),而且线的转折次数不超过两次,那么这两个棋子就可以在棋盘上消去。不好意思,由于我以前没有玩过连连看,咨询了同学的意见, 连线不能从外面绕过去的,但事实上这是错的。现在已经酿成大祸,就只能将错就错了,连线不能从外围绕过。
玩家鼠标先后点击两块棋子,试图将他们消去,然后游戏的后台判断这两个方格能不能消去。现在你的任务就是写这个后台程序。


[align=left]Input[/align]
输 入数据有多组。每组数据的第一行有两个正整数n,m(0<n<=1000,0<m<1000),分别表示棋盘的行数与列数。在接 下来的n行中,每行有m个非负整数描述棋盘的方格分布。0表示这个位置没有棋子,正整数表示棋子的类型。接下来的一行是一个正整数 q(0<q<50),表示下面有q次询问。在接下来的q行里,每行有四个正整数x1,y1,x2,y2,表示询问第x1行y1列的棋子与第 x2行y2列的棋子能不能消去。n=0,m=0时,输入结束。
注意:询问之间无先后关系,都是针对当前状态的!


[align=left]Output[/align]
每一组输入数据对应一行输出。如果能消去则输出"YES",不能则输出"NO"。


[align=left]Sample Input[/align]

3 4 1 2 3 4 0 0 0 0 4 3 2 1 4 1 1 3 4 1 1 2 4 1 1 3 3 2 1 2 4 3 4 0 1 4 3 0 2 4 1 0 0 0 0 2 1 1 2 4 1 3 2 3 0 0


[align=left]Sample Output[/align]

YES NO NO NO NO YES


[align=left]Author[/align]
lwg
//终于把这题过了
//好久之前就看过这题了、这次终于过掉咯、(*^__^*) 嘻嘻……,DFS

#include <iostream>
#include <stdio.h>
#include <algorithm>
#include <string.h>
#include <queue>
#define N 1002
using namespace std;
struct status
{
char s;
int n;
};
int dir[4][2]={-1,0,1,0,0,-1,0,1};
char di[4]={'u','d','l','r'};
int map

;
bool h

;
int n,m;
int sx,sy,ex,ey;
bool flag;
void DFS(status direct,int x,int y)
{
if(flag) return;
int i;
int a,b;
status tp;
for(i=0;i<4;i++)
{
a=x+dir[i][0];
b=y+dir[i][1];
if(a<1||b<1||a>n||b>m||h[a][b])
continue;
tp.s=di[i];
tp.n=direct.n;
if(tp.s!=direct.s)
tp.n++;
if(tp.n>2) continue;
if(a==ex&&b==ey) {flag=1;return;}
if(map[a][b]) continue;
h[a][b]=1;
DFS(tp,a,b);
h[a][b]=0;
}
}
int main()
{
int i,j,q;
int x,y;
status tp;
while(scanf("%d %d",&n,&m),n||m)
{
for(i=1;i<=n;i++)
for(j=1;j<=m;j++)
scanf("%d",&map[i][j]),h[i][j]=0;
scanf("%d",&q);
while(q--)
{
scanf("%d %d %d %d",&sx,&sy,&ex,&ey);
if(!map[sx][sy]||map[sx][sy]!=map[ex][ey])
{
printf("NO\n");
continue;
}
if(sx==ex&&sy==ey)
{
printf("YES\n");
continue;
}

flag=0;
h[sx][sy]=1;
for(i=0;i<4;i++)
{
x=sx+dir[i][0];
y=sy+dir[i][1];
if(x<1||y<1||x>n||y>m)
continue;
if(x==ex&&y==ey) {flag=1;break;}
if(map[x][y]) continue;
tp.s=di[i];
tp.n=0;
h[x][y]=1;
DFS(tp,x,y);
h[x][y]=0;
if(flag) break;
}
h[sx][sy]=0;
if(flag) printf("YES\n");
else printf("NO\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: